Cannot access WDMyCloud from Windows 10 laptop PC

Have a WDMyCloud device installed for a few good years now.
All devices (Windows laptops, iPads, and iPhones) have connected fine.

About one year ago got a new work laptop (pretty standard Dell Latitude) Windows10 and CANNOT see my WDMyCloud device. Have WD Access installed and when select WDmyCloud > Open… nothing happens.
I have tried this with VPN on and off and the result is exact same: cannot access!
I need to back up my computer so would appreciate some guidance.

Have at 2 other Windows slightly older Windows10 laptops from other family members at home which connect fine to WDMyCloud…

Haven you checked that SMB1.0/CIFS is enabled in Windows 10? Microsoft has this option disabled on new installs of Windows 10 and disables it through a recent update.

How to Enable SMB 1.0/CIFS File Sharing Support on Windows 10
https://support-en.wd.com/app/answers/detail/a_id/4155

Also ensure the Windows Network Profile option is set to Private and not Public.

Hi Bennor,
Thanks for getting back to me.
Enabled SMB1.0/CIFS… rebooted the laptop computer and my Network Profile was set to Private anyway.
Unfortunately no change… go to WD Access > WDMyCloud > Open > nothing happens…
Any clues?
Thanks again.

What happens when you use Windows File Explorer (or if using Mac, the Finder) to open up the My Cloud on the local network?

Other troubleshooting steps to check. Are both the laptop and the My Cloud on the same local network? Are both of them using IP addresses from the same IP subnet? Example each has an IP address in the 192.168.1.x range.

If your problem is trying to access a remote network My Cloud then its a separate issue. If using VPN to access the remote network, check that the VPN tunnel is operating correctly and that the VPN client is not being isolated by the VPN server. Officially the only methods of remote access to a My Cloud that WD will support is the My Cloud.com web portal, insecure FTP, and the WD My Cloud app for Android/iOS.

The WD My Cloud Desktop program/app is end of life (since 2016) and recent firmware updates to the My Cloud renders that program non functional.

As further troubleshooting steps, disable any security software on the computer as some have a tendency to interfere or block access to the My Cloud.

Hello again Bennor,

Apologies but during the week is difficult for me to communicate due to my busy work schedule.

This is my home wireless network. MyCloud device is connected to the router.
Again 2 Windows 10 laptop computers (personal) can see/access the MyCloud device without any issues.
Also all iPhones and iPads at home can access the MyCloud device fine.

It is only my “new” Windows 10 work laptop computer provided my employer back in August 2019…
Again my previous work laptop computer was able to access the MyCould device provided the VPN was off.

My work laoptop computer is pre-configured my my employeer’s IT department and if your suggestions are to deep dive on the overall PC configuration I am not savy enough. I was able to follow your
initial instructions… but as reported did not solve the problem.

Funny enough if I Select the Settings option in MyCloud access I can actually see, via the web browser MyCloud settings… and navigate through the various options: Home - Users - Shares - Cloud Access - Safepoints - Settings…

So this is really strange… all I need is to back-up files from my work laptop by dragging flies from my work laptop into the appropriate directories in MyCloud device using Windows Explorer…

Not sure if you require any additional information.

Thanks again,

Forgot to mention when I open a Windows Explorer windows cannot see the MyCloud device on the left… there is nothing under the Network icon. I have a wireless printer/scanner on the very same home network which I can access fine from my Windows 10 work laptop computer, provided VPN is off.

And yes each device on the network has it is own IP address.

Thanks again!

Have you tried contacting your businesses IT department (the one’s who gave you the laptop) and ask them if any of their configurations or settings are interfering with accessing the My Cloud on your home network?

For most, enabling SMB1.0 and setting the Windows Network Type to Private solves most problems. That indicates there may be additional software, like security software, present that is blocking access to local network devices.

With the problematic laptop can you access the My Cloud Dashboard? Can you, when using Windows File Explorer, access the My Cloud using the My Cloud’s IP address?

Hi Bennor,
Was able to chat with Ethan at WD Tech Support.
It seems it is indeed a issue with company IT security policies. Ethan provided me with the link https://support-en.wd.com/app/answers/detail/a_id/18499/ which explains the error I get when I type the //ipaddressno. for my WDMyCloud device, and suggests solution.
So I guess at east I know now it may be solvable if the IT department for my employer authorises a guest access to my device.
I have reported it and waiting on a reply.
So the above is just a bit of feedback, and once again thanks ever so much for your efforts in trying to resolve the issue reported.

A problem that I faced in accessing the MyCloud through windows network, after I upgraded Windows 10 from version 1909 to 2004 in June 2020:

Everything was working fine in Windows 10 version 1909, but after upgrading to 2004, I was getting message about group policy preventing guest access.

In version 1909, the solution that was needed was to enable guest access in Group policies settings window.

BUT, in 2004, this is “broken” from the settings window and needs to be done through RegEdit (even if you had already done it in 1909:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters]
“AllowInsecureGuestAuth”=dword:1