I can't access to my cloud with my computer

Hello everyone !
I have a WD MyCloud Product but i have a problem with it
With my Macbook Pro i can access to the Cloud and when i double-clicked on the logo in my “reseau” folder, i access to the folder (it’s look like an normal folder)
But when i try to access to my cloud from my computer (with Windows 10) when i clicked on the logo of my cloud, it’s opened a internet link and i am on the website (this one for setup the cloud)
So Please can you help me ? Thanks You

Mikael

On the Windows 10 PC, make sure SMB 1.0/CIFS is enabled.

How to Enable SMB 1.0/CIFS File Sharing Support on Windows 10
https://support-en.wd.com/app/answers/detail/a_id/4155

I LOVE YOU MEN XD
I search a solution since 1 week, thank you very much

HI all,

I have similar problem and tried to do the Enable SMB 1.0/CIFS File Sharing Support setting. The problem still exists.

I manage to access the public file using my desktop (with Windows 10). I assigned a network drive before but suddenly the link does not work recently. I wonder if my recent change of router cause that.

When I clicked on the mycloud logo, it goes to the website instead. Searching for whole day in Q&A but cannot solve the problem. Any more advices that could help? Thanks a lot

Bondson To

Make sure the Network Type is set to Private not Public. Also, as a troubleshooting step, disable any third party security/antivirus software to see if the issue persists.

Recheck that the SMB1.0/CIFS option wasn’t disabled (again) by Microsoft. It is possible a recent update to Windows may have disabled it (again).

Try accessing the My Cloud, in Windows File Explorer, by it’s IP address instead. Example: \\192.168.1.10

There are other rare instances where one’s router could be blocking access to the My Cloud if WiFi client isolation is enabled within the router or the computer is on a guest WiFi network using a different IP address subnet than the wired network connection of the My Cloud.

Sometimes it takes several hours for the NAS to show up in file explorer. This was a
“benefit” introduced with Windoze 10