I cannot access My Cloud after formatting my computer

Hello. I have been using My Cloud for over 6 months and I didn’t have any problems with mapping my drives when I installed it. Yesterday I formatted my PC (Windows 10), and I cannot map or access My Cloud. I installed WD Access, it doesn’t have the mapping option either. When I click “Open”, nothing happens. When I enter the Map Network drive menu, and I type in “\192.168.1.99”, I can see “WDMYCLOUD” but when I try to access it, I get the error “Windows cannot access \WDMYCLOUD”. I alson checked if Kodi can access it. I can access my files when I select NFS, but not when I select SMB. I also have an Nvidia Shield TV, which uses SMB 1.0 and I could map that drive with no problems.

Microsoft has disabled SMB1.0 in later updates of Windows 10 due to security issues present in SMB1.0. Reenabling it may solve the inability of Windows 10 to see the My Cloud.

Thank you for your answer. But like I said, I can see My Cloud, but I cannot access it. And SMB 1.0 is already enabled because I can access Nvidia Shield TV which uses SMB 1.0.

As a troubleshooting step. Actually check, if you haven’t done so already, the Windows Features setting to ensure SMB1.0 is actually enabled. One of the recent Windows 10 updates will actually disable the SMB1.0 setting.

Can you access the My Cloud Dashboard using a web browser?

Is Kodi running on the same Windows 10 PC?

SMB1.0 is actually enabled. I can access the My Cloud Dashboard using Google Chrome. And Kodi is running on the same Windows 10 PC.

I have solved the problem by adding a Windows credential and then rebooting the My Cloud.

Hello, Xeriphas, I am having exactly the same issue you describe. Could you be a little more specific about your fix. I tried adding a credential for “\mycloud” without success. All suggestions welcome.

First, reset your network: https://support.microsoft.com/en-us/help/10741/windows-fix-network-connection-issues
And then follow the steps in this video: https://www.youtube.com/watch?v=9uSux3AhTN0
But don’t forget to type in the correct device name found in the My Cloud Dashboard.
And finally, restart both your router and PC.

1 Like

This restored my connectivity, after then rebooting all my devices in following order (1) router, (2) WD Drive, and then (3) PC. Many thanks,

Thank xeriphas and Lorob1,

Nice dialogue but so far the latest version of Windows sent out to MS Insiders does not respond to even the new credentials or changing SMB 1 or 2 or 3. It does not matter also if you try all caps, when MS got rid of HomeGroup, they also took lots of PC chat across the router. With the version in final beta, if you want to chat to another PC or even Cloud device, you will pay. They even take away access with the IP address. I changed the name to all caps and now the IP addr doesn’t work for access so I will go back to WDMyCloudMirror and plan on getting Windows 7 to running on this machine or roll back to an earlier version of Windows 10. I can live without win 10 if I have win 7 and My Cloud.