Backup Doesn't Backup All Files - says "Access is denied" in view files that are not backed up

I have been using the WD Smartware software for my WD My Cloud device I have it set to backup on the go.

Similar to how I had the WD My Book setup.

However it doesn’t back up all my files. One folder from instance has 29 files in my Documents of the PC and the Mycloud only has 20 of those documents. The missing files range from pictures to words documents and even PDF’s. I did notice that some files were pending. I have tried removing the software and starting again, I’ve changed folders, new software update, but it is still the same. I have even left the PC on for a couple of days but still the same.

I would like to find a fix for this as I like the way the backup keeps the MyCloud up to date on the network and I can access files and pictures from any device on the network or via the web on my laptop or mobile.

How long have you had your My Cloud and when did you start the backup? Pending files are just that, give them time to be backed up. See example image below. Your My Cloud works just like your printer, if you send five documents to your printer to be printed it can’t print all of them at the same time, they are placed in Queue and printed in the order that you sent them.

I have had the same pending files for over a week. I am aware that other users have found they have files missing on a backup forum. Would it be possible for you to check some of your files to see if they have the same amount of contents within them as the same file backed up on your MyCloud Drive?

I have noticed something that might be the issue, by clicking the “View files” under the “Files Not Backed Up” display in the bottom right hand of your diagram above it says “Access is denied” and they are all the files that are missing. 1245 files totalling 6.31GB of data. And at the top it says 51.84 GB of 58.17 GB copied and remains like that constantly and had done for a week.

Why are the backup of these files “Access is denied” ?

1 Like

I have switched from Category Backup to File backup system. But nothing has been backing up for 15 mins. I have removed the old backup file to have a clean backup. I have attached a PDF screenshot of the program. Am i doing something wrong? Is there an alternative software beside WD Smartware I can use to backup to my WD MyCloud EX2 Ultra?

Thank you
Have a nice day

Doc1.pdf (128.1 KB)

Has there been any resolution to “Access is denied” and WD Smartware not completing a full backup? I’m having same issue, 65 files or 43 MB out of 190 GB will not backup. Under View Files, first it will say File Pending Backup for each file, then “Access is denied”. I left running over night, no change. I just started having this issue (4/22/2021) on a Windows 10 Pro (Version 20H2) laptop using WD Smartware (Ver to backup to a PR2100 4TB NAS.

I have the same issue with my WD MyCloud EX Ultra II. 1,972 files, 21.99 GBs just sitting there with the progress bar showing 1.47 TB of 1.48 TB copied. I’ve checked to be sure the folders are shared. Would someone please address this issue?