All Shared Folders disappeared After the 1.05.21

HI every one,

Need Urgent help please,

All my shared folders dissapeared after the update to the new Firmware, The available space didn’t change so they should be still there somewhere but can’t access them.

Please help, all my work is on it

Thanks a lot

The same has happened to me twice; both times I crossed my fingers and just re-added the shares through the web GUI with exactly the same name/location etc. as before. Both times it picked up the still-existing folders as shares again as if it had never happened.

Can’t guarantee anything; YMMV.

Thank for the reply, at Least there is hope for recovery,

This is really disapointing for WD to have this kind of problem in a device that is supposed to be offering the data safety service.

Did you by anychance reboot the system before you recreated the shares? 

And by web GUI do you mean the dashboard of the device or a different interface please advice, just want to make before I do anything.

Thanks again

The first time it happened I tried a reboot in the hope that was all it needed; the second time was immediately after I rolled back the firmware to the previous version (I was on the Beta test); the device had just booted up, and I went right ahead & recreated the shares.

By ‘Web GUI’ I mean I open my browser and navigate to the EX4’s IP address. I think this is what’s usually called the dashboard?

Both times I had also SSH’d into the device to browse around & check the info was still there.

OMG , sad to heard it.

Here my experienced during upgrade this version FW.

i have just tried manual down FW from below link  , found the first tried of download fw files was currupted.(after upzip nothing in folder and observed the download file size is about 4MB)

Again retried redo download , sucessfully download " My_Cloud_LT4A_1.05.21.bin " file size in win7 show 93,293Kb

after upzip the " My_Cloud_LT4A_1.05.21.bin "   get   " My_Cloud_LT4A_1.05.21 "   file size in win7 show 93,481Kb

i have  connect to dashboard , under setting - > firmware update - >  manual update

The update progress showing hang during at 29% , and the WD EX4 panel show firmware update failed.

what is the FW file correct  or corrupted ??!!!  why i have run manual firmware update failed.

luckily WD ex4 still working…

OMG , after reboot my power button LED show red blinking !!!

Naf, Thanks a lot for your advice, will do that hopefully I will not forget a folder.

How are you with SSH?
Internally your drives are mounted under /mnt/HD/HD_#2 where you replace # with a, b, c, or d depending on the drive number. (Just run the ‘ls’ command in /mnt/HD/ and see which are there).
If you cd into each one in turn and run ls, then all of your shares will be listed as directories so you can make a note and not forget any.

If you have the power light blinking red it’s not good. If you can connect to the  web interface and click on the bell (alerts) to see if you can get more information.

Hi Guys,

Same thing happen to me, what I did is make all the folders turn into public. it worked on me hope this solve this issue