After firmware update - Time Machine Backup cannot be found

I’ve just discovered that my MAC has not done any TM backups since Jan 11th 2022.

By coincidence - my MyCloud device had an auto firmware update on the same day.

This is more than just coincidence in my view as my backups have worked fine
I now have the following error messages when trying to execute a TM backup:

  • Backup file on MyCloud local says “Zero KB of 2.91 TB available”
  • The backup disk could not be found. Make sure disk is connected or select different disk"

When I connect to the MyCloud server via MAC Finder and select the TimeMachine backup file - I get the error “You do not have permission to access this server”.

However I am able to access all other folders on the server - for example backups of photos from mobile phone.

Has anyone else reported this or had a similar problem?
Does anyone know the fix to the above?

PS: I’m in the UK - when calling the WD contact us support helpdesk number and all I get is “sorry the system is busy”…?
Thanks,

Please see the following article:

My Cloud Home and My Cloud OS 5: macOS Time Machine Backup and Finder Connection Error

If you continue to see issues, please open a case with our support team for further assistance:

https://support-en.wd.com/app/ask

Same here ( thread ). Got in touch with WD Support but no solution yet.

These are the instructions recommended by WD staff:

I understand that you have tried the solution below but still not working :

My Cloud Home: macOS Time Machine Error “Backup Disk Not Available”

My Cloud Home: macOS Time Machine Error "Backup Disk Not Available"

Please follow the instructions in the links below:

MY CLOUD OS 5: MACOS TIME MACHINE BACKUP TO A MY CLOUD

My Cloud OS 5: macOS Time Machine Backup to a My Cloud

TIME MACHINE BACKUP TAKES A LONG TIME TO COMPLETE ON NETWORK STORAGE DEVICE

Time Machine Backup Takes a Long Time to Complete on Network Storage Device

INITIAL TIME MACHINE BACKUP FAILED OR COULD NOT COMPLETE

Initial Time Machine Backup Failed or Could Not Complete

MACOS TIME MACHINE ONLINE USER GUIDE AND SOLUTIONS

macOS Time Machine Online User Guide and Solutions

Maybe they are useful for you. My backups are still not working.

There seems to be nearly countless bugs in TM for Monterey and Apple will eventually get to most of them which is not to say WD can do no wrong, but all this started with Apple getting rid of AFP which ironically is something Apple mandated then deprecated for TM. There are long threads in many forums on this problem, among them is this one:

it looks like that’s yet another TM bug in Monterey. :frowning:

I’ve heard of that, too. Strangley it started for me on the day WD released their new software cutting support for afp. So either WD did not implement smb correctly or Apple did it in Monterey.

After further diagnostics and locating TM backup folder on mycloud drive - trying to access folder returned message saying file no longer exists which is baffling. I’m running an old iMac with OS High Sierra 10.13

Yep,

I’ve got the same problem too.

MacOS v10.14.6 and I’ve been unable to backup since the latest WD update.

M

1 Like

This is outrageous… i cannot backup since 17th, shortly after receiving an email from WD telling me I will have to use another link to connect online… link doesnt work:
auth0.accounts.westerndigital.com
Cherry on the cake: Time Machine doesnt find the disk anymore, even if I see it in my Network, and also all the previous backups. can someone hit me when we find an answer?
hopefully i will not face big issues with my mac by then, otherwise, i have no backup. will buy an additional disk, just in case if… thanks WD! great job

Ok the answer is here:How To Map a My Cloud or NAS Device on macOS
you have to reconnect the driver to your network if it is on wifi:
-open finder,
-in the menu: Go>Connect to Server
-enter the SAMBA connection: smb://MyCloud-XXXXXX.local
-select Guest,
-Mount on the folder you want: timemachine backup

Am connected via ethernet
Have already done as you suggest - reconnect via SMB
Still does not connect

Thanks

you use a MycloudHome connected to your wifi router?

Yes

can you describe what you see when you enter the smb://MyCloud-XXXXXX.local

Raised a support ticket and got a response.

What appears to have fixed my system was going back to initial setup instructions and “important” information like ensuring the TM share had “web access” turned off, ensuing TMbackup share size was set at 100%, only one user having access to share, I chose “admin”, reconnecting to share using registered user.

Check here:
https://support-en.wd.com/app/answers/detail/a_id/30151#subject1

Thanks, Dave

I re-adjusted various settings on mycloud device based on this feedback from WD tech support - and have got my system working again. Key changes made are indicated in my earlier response.

Dear DAVID CARSON,

Thank you for contacting Western Digital Customer Service and Support. My name is Constantine B…

I understand that you are having issues regarding your backing up to Time Machine.

Can you turn off File Sharing & re-enabled i?

On the Mac/TM server machine, disabling File Sharing, (waiting 10 seconds) & re-enabling, allowed the Mac to complete the TM setup process successfully without error 13.

My Cloud OS 5: macOS Time Machine Backup to a My Cloud

https://support-en.wd.com/app/answers/detail/a_id/30151

My Cloud OS 5: macOS Time Machine “Backup Disk Not Available” or Finder “Connection Error”

https://support-en.wd.com/app/answers/detail/a_id/32003

Contact me again in case the problem persists

Please let me know if you need anything else & i will be happy to assist you!

Sincerely,
Constantine B.
Western Digital Customer Service and Support
https://www.westerndigital.com/support

Please note a 30-second support survey will be sent to your email later. We look forward to your feedback. Thank you for your understanding and support.

Note: If you have not visited our community forums, please make sure to do so. You may also find answer(s) to your question(s) there. Link to WD community forums at: https://community.wd.com .

This electronic message contains information from Western Digital, is intended only for the use of the addressee and may contain information that is confidential. The dissemination of this information is strictly prohibited. If you have received this electronic transmission in error, please respond back to this e-mail or contact us by phone.

In order to process your email, please do not remove this reference #: 220127-001023

Hi carsondave,

seems you have a My Cloud device not a My Cloud Home. There is no setting like share size xx%, … in My Cloud Home settings. Or am I not seeing something?

Yes - I have a basic My Cloud device - apologies if I gave a different impression or used wrong terminology.

Always great to hear that people solve their problems, really.

It’s just the wrong forum. :wink:

Sorry @JoeTaxpayer but you are in the wrong subforum. This is about the My Cloud Home not the EX2.