MyCloud NAS No longer connects to Mac Time Machine

I have 2 MacBook Air M1 machines. Had been using Time Machine with a MyCloud NAS for over 3 years. No problems. About 2 months ago, I could no longer backup to the MyCloud on one of the MacBook Airs (running Sonoma). Kept showing Preparing backup and then timing out. Rebooted all devices reconnected ethernet, still no go. Removed the MyCloud disk from TM and tried to re-add it. Now it can’t find it and can’t list it.

The second MacBook Air (Monterey) was still able to backup to MyCloud but then about a month later, I can try to backup but only get “Looking for backup Disk” and then it times out. If I remove the MyCloud from the TM prefs, it will no longer be able to re-add it.

I can mount the Time Machine backup volumes without any problem. Just can’t connect to the backup disks. Anyone else experiencing this? thanks.

Apple and WD have deprecaited AFP. Ensure you are using SMB instead when connecting to the My Cloud Time Machine Share.

How to Use macOS Time Machine Backups with a My Cloud OS 5

macOS Time Machine “Backup Disk Not Available” or Finder “Connection Error” on My Cloud OS 5

Thanks for your help. I can mount the disk using SMB and access my Time Machine backup folders. It is when I try to ADD DISK (+) to TM. MyCloud does not show in the available disks, and cannot select USE DISK. My other TM external disks show and are available as backup disks.

I have the EXACT same problem. I think it coincided with an Apple update. For years, everything worked fine but now when I go into my Time Machine settings, there is no WD/NAS TimeMachine Backup to use as a backup. I can access the existing backups for all my Macs but none of them see the NAS device as a viable option to back up on. Have you gotten any PM’s from WD about this? or does anyone know of a new thread im missing on a fix? So far there are no new updates for the firmware.

Try this,

Thank you for the attempt, but that did not work. currently have no drive for my backup. when I try to add a backup disk, I get a msg that no drives are available…
db

Hi,

Can you tell us the version you are running? macOS and My Cloud OS?
Did you try to disable and enable again the Time Machine backups option on My Cloud OS? (settings > general > Time Machine backups)

Good luck!

First, awesome, thank you for reaching out.
yes, I tried disable/enable. Tried changing sizes too. Just did a NAS update yesterday and tried it all again.

MacOS is Sonoma 14.4.1 on both of my Macs which are having the same problem from the same date. which I can’t tell you when it started b/c I also deleted my backups so it could start fresh but I think it was sometime in feb/march.

NAS device is currently running 5.28.105 (updated yesterday)

db

If your MyCloud NAS is no longer connecting to your Mac for Time Machine backups, there are several troubleshooting steps you can take to resolve the issue:

  1. Check Network Connection:

    • Ensure that both your MyCloud NAS and your Mac are connected to the same network and that the network is functioning properly.
    • Verify that the NAS is accessible from your Mac by trying to access its web interface through a browser.
  2. Verify Time Machine Compatibility:

    • Ensure that your MyCloud NAS model is compatible with Time Machine backups. Some older models or firmware versions might not support newer macOS versions or Time Machine protocols.
  3. Check NAS Settings:

    • Log in to the administration interface of your MyCloud NAS and check the settings related to Time Machine backups. Ensure that Time Machine support is enabled.
    • Verify that there is enough storage space available on the NAS for Time Machine backups.
  4. Restart Devices:

    • Sometimes, simply restarting both your MyCloud NAS and your Mac can resolve connectivity issues.
  5. Update Firmware and Software:

    • Ensure that your MyCloud NAS firmware is up to date. Manufacturers often release updates that improve compatibility and fix bugs.
    • Check for any macOS updates on your Mac and install them if available, as they might include fixes or improvements related to network connectivity.
  6. Reset Time Machine Preferences:

    • On your Mac, go to System Preferences > Time Machine.
    • Remove your MyCloud NAS from the list of backup destinations by clicking the minus (-) button.
    • Add it back by clicking the plus (+) button and selecting your NAS again.
  7. Check Firewall and Security Software:

    • Temporarily disable any firewall or security software on your Mac that might be blocking Time Machine from accessing the NAS.
    • Ensure that your NAS settings allow Time Machine access through any built-in firewalls or access controls.
  8. Test with Different Settings:

    • Try connecting your MyCloud NAS directly to your Mac via Ethernet cable (if possible) to rule out any issues with your Wi-Fi network.
  9. Consult Manufacturer Support:

    • If none of the above steps resolve the issue, consult the support resources provided by Western Digital (the manufacturer of MyCloud NAS) or Apple for further assistance.

By systematically going through these steps, you should be able to identify and resolve the issue preventing your MyCloud NAS from connecting to Time Machine on your Mac.

2 Likes

Thanks for your help.
Tried all of the listed remedies. Still no go. I removed the MyCloud.local disk on TM and attempting to re-add it, when hitting the “+” button, It shows TIME MACHINE BACKUP on WDMyCloud.local. Hit “Set Up Disk”… Then Connect As; Tried both Guest and Registered User. It mounts the drive on the desktop and then it just hangs forever and then I have to force quit, getting a "Time Machine System Settings not responding. "

I can also access the MyCloud dashboard via the webpage. I can mount the WD MyCloud drive and access all of the previous backups with no problem. Just can’t add it back in the TM prefs available disks to use for TM.

@Irene.bellsouth i tried but still not working any other steps