WD MyCloud not backing up to Time Machine - Macintosh

About 9 months ago I bought a WD MyCloud drive for use with my Macintosh, specifically for Time Machine backups.  It worked great for a while, then 2 months ago it stopped backing up to Time Machine.  Time Machine says it is unable to write to the drive and I should run the Disk Utility if I continue to have problems.  I can copy files from my computer to the drive without any problem.  I didn’t change any settings, so I don’t know what’s causing the problem.  Does anyone have any ideas?

I also can’t access the drive from anywhere besides my home network, but that problem is for a separate topic.

The firmware I have is: WDMyCloud v04.00.01-623 : Core F/W



What happens if you try to map the Time Machine share using the AFP protocol as opposed to SMB? Do you encounter the same issue when your Mac is connected directly to the same router as your WD My Cloud as opposed to using a wireless connection?


I’m not sure what you mean by AFP protocol or SMB.

I haven’t tried directly connecting to the router, but I will give it a try.



A few days ago I did a System Only restore, which deleted the user names.  Time Machine was trying to connect to the MyCloud drive via the username Time Machine, which no longer existed after the restore.  I changed the Time Machine configuration on the MyCloud drive to backup to an existing username, and now a backup is currently in progress.  It’s backing up 356 GB and has 15 hours to go (over wireless). Before the MyCloud drive stopped backing up a few months ago, I don’t think the backups took this long, but I’ll see how this goes.

After 24 hours it has backed up 193 of 356GB, with 16 hours to go.  Based on this time frame, I think something is still not rigiht.