WD My Cloud Time Machine w/ Macbook Retina

Okay, I’ve pretty much had it with the whole Time Machine backup “capability” of WD My Cloud. I’m extremely disappointed.

Let me say that I love most of WD My Cloud capabilities. It works great with Windows (even 10), and I have no issues with it. But with Mac/Time Machine? It’s a complete disaster so far.

  1. On Mac, connecting to WD My Cloud takes a while. Sometimes 30 seconds or so. I’m not sure why, but it’s weird. With Windows, I get an instant directory/file list with no waiting (fast switch connected). But with my Macbook, it can take up to 30 seconds to list the contents of a directory - if not more, sometimes. Why? Not sure.

  2. It doesn’t work with Time Machine. At all. This is a problem, because I got it partly for Time Machine capabilities. Yes, I connected as guest to the share, yes I triple-checked the settings in the UI, but it has major issues. For instance, like many others, my Macbook will connect and prepare the backup, and get partway, and then, for some odd reason, it will fail. I’ve tried deleting the file and doing it again, over and over again. But as it takes a while to transfer even partially (it is incredibly slow), this is an experiment which has lasted a few weeks and I’m tired of it.

Also, another thing it does is after failing at doing an entire backup, it will later say that it cannot backup the laptop with the current Time Machine backup, and Time Machine insists on making a brand new fresh backup - each and every time.

I’ve researched this on Google and have had many suggestions which I’ve tried, including resetting permissions and all the rest, to no avail. It’s just not working. Also, why is it so bloody slow? I might add that even hooked up with an ethernet cable, it is still incredibly slow (fast switch notwithstanding).

I’ve seen a lot of posts about how many Mac users have regretted getting it because of this, and you can count me in on that. I wouldn’t be so disappointed if it wasn’t for the fact that WD doesn’t appear to give a whit about us and address the issue directly or tell us how to fix this problem.

One last thing, non-Mac related: For some reason, the web UI for configuring the drive is often stalled out and/or slow. In fact. it seems to vary at random times. I have no idea why. You’d think that a simple web interface would load up within seconds on a local network - wired or non-wired - but such is not the case. I often find myself having to cold boot the entire device because of the interface being as slow as mud. Other than that, it seems to mostly work fine for windows.

So, any suggestions would be appreciated. And, in the meantime, I’m just going to chalk up the entire WD My Cloud to being an incredibly bad investment of my time and money. If somebody from WD actually helps me to get it working the way it was advertised, then I’ll change my mind. But then, they should fix the how-to and their videos with the new information so that others don’t go through what some of us have been going through.


What version of mac OSX are you using on your computer?

The latest El Capitan. 10.11.1

But this actually happened with Yosemite as well.