WD MyCloud not backing up Time Machine since upgrading to Monterey 12.4

Hello - I have been backing up via MyCloud (2 TB, single bay) for about 5 years, occasional glitch that I’ve managed to sort (re-boot, etc.), otherwise back-ups happen automatically on my early 2015 MacBook Air, 8GB. But I’ve not been able to back up for a couple of days, and reccently upgraded to OS Monterey 12.4. Could this be the problem? It prepares for back-up, then stops.

WD MyCloud firmware is up-to-date, I’m running os5 and apart from not backing-up, no other issues with my NAS, works fine on Mac and iPhone. I’ve re-booted, and logged out and in again and just pulled cables out (in frustration!) Haven’t tried a wired connection, though… Can back up to a portable hard drive, so would seem it’s not Time Machine per se.

Any suggestions gratefully received.


Check that you are using SMB (Samba) and not AFP to connect/access the My Cloud. Apple has depreciated AFP. One will have to reconfigure Time Machine. WD has several Knowledge Base articles on this:

My Cloud OS 5: macOS Time Machine “Backup Disk Not Available” or Finder “Connection Error”

Apple File Protocol (AFP) is no longer supported on My Cloud OS 5 firmware 5.19.197 and higher.
For more information, please refer to My Cloud OS 5 firmware release notes

  • TimeMachine Backups must be reconfigured using Samba (SMB)
  • Connections to shares must be reconfigured using Samba (SMB)

My Cloud OS 5: macOS Time Machine Backup to a My Cloud

Thank you Bennor. I recall had to change change how I connected to Server under the “Go” menu, but that was a little while ago, though, in comparison to this.

So what you say makes sense, I think - it’s late where I am, and it’s a long woking day Monday, so won’t be able to do more until Tuesday day off.

Thank you for the links.


Have had no luck. Have been through the article links you sent. I select Time Machine disk to use as backup, log in with user name and password, eveything behaves as though backup is gong to happen, goes through to “Preparing backup”, and - nothing. Stops. I am configured to SMB not AFP and have not trie wired connection as I can connect wirelessly to server under “Go”.Not aware it was as a result of anything I did, but my NAS did indexing last night after I had a go at resolving issue.

Does your My Cloud have enough free space to perform the Time Machine backup? Check the Capacity section of the My Cloud Dashboard to see what it indicates for free space. Other things to check. Ensure the Time Machine service on the My Cloud is enabled (turned On), select the Configure link and make note of the Share that is configured to host the Time Machine backup files and make sure the Maximum Size is set to use enough space to hold the Time Machine backup (generally one selects the maximum capacity). Ensure that you are instructing Time Machine on the Apple computer to backup to that Share.

OS5 My Cloud User Manual | Configuration Settings | General | Mac Backups

Thank you for your reply, Bennor.
Capacity section on Dashboard is 561GB. Yes, already checked -Time Machine is enabled, checked Configure and the Share is TimeMachineBackup, Maximum Size is set - 1.9TB, 100%. I am instructing Apple computer to back up to that Share, TimeMachineBackup (My Cloud.local, etc.). Drive is partitioned and I back up to one and store music and other assorted files on the other, which counts for 105MB. On a 2TB server…

When doing a backup one has to ensure they have enough free space (free capacity). If you only have 561GB of free space that may present an issue depending on how much space you are attempting to backup on the Mac using Time Machine.

A quick internet search for Monterey 12.4 Time Machine brings up a number of posts on issues people are experiencing.



If you haven’t done so already you may want to consult with Apple Support or their forums to see if they have any suggestions.

Thnak you Bennor! Makes sense that it could well be the Monterey 12.4 update I reccently did (because all was fine before that, I’m sure), causing a possible G-Drive disconnect. Not sure what that means, so I’ll dig some more. I’m nearer and Apple premium reseller, Seclet, so will ask them first, then go along to an Apple Store if necessary. I’ve discoved that my old iPhone 8 (which died) and my new iPhone 12 was/is backing up the camera roll via the App, so I’ll delete the older backup.

Thanky ou again Bennor, I apprciate your help with this.

My MacBook Pro (14-inch, 2021) running Safari Version 17.5 stopped backing up through Time Machine about 2 months ago. I have a WD external drive connected to my wireless router. This has been my backup drive for about 2-3 years. I have erased my backup history. I have removed the backup disc and reloaded it. I have tried to follow the recommendations in Apple Comunity regarding this problem, but so far no success. Not sure what to try next? Do I need to get a new external drive, different vendor?

Any suggestions appreciated.


Do you have a WD My Cloud device? This topic is generally for discussing the WD My Cloud and issues with Apple’s Time Machine backup with the single bay/single drive WD OS5 My Cloud device.

If you do not have a WD My Cloud then look for subforums discussing your router, and or the external hard drive you have connected to the router. Also check with Apple support forums since Apple Time Machine issues are fairly common and there may be suggestions in those Apple centric forums for resolving your issue.

What is the make/model of the router? There are specific websites discussing certain router brands/models and their issues.

Western Digital External Drives

The WD My Cloud is not an “external hard drive”, it is a network attached storage device (NAS) which operates differently and has a different function/purpose than a router with a USB hard drive attached.