Sierra Update TimeMachine - MyCloud Mirror no longer recognised

I’m a newbie to the site.

I have updated my iMac software from Lion to Sierra. This has resulted in my iMac Timemachine no longer recognising MyCloud Mirror (therefore not backing up)

I have checked the firmware on the MyCloud and it’s upto date.

I have even created a new share for the TimeMachine but, still get an error saying disk is no available?

I have done a soft re-boot (4 sec version) but it’s still coming up with the error.

Any suggestions would be appreciated…

Thanks

Starting from Mountain Lion, protocols for Apple Time Machine were significantly changed. What happens if you manually map your Time Machine share as a registered user using the AFP protocol?

I have logged an issue with WD support who are looking into this issue.

Interestingly, I tried a ethernet cable connection to the MyCloud Mirror and sure enough if the iMac is connected via ethernet to the router rather than wifi, it is able to back up the MyCloud.

However, trying to do this via wifi does not work so, it seems something has changed since updating the iMac to Sierra with the wifi connections to the MyCloud Mirror?