Can't Connect to MyCloudMirror with Os Sierra

I have been backing up with Time Machine on my MyCloud for 2 years without problems. Since I upgraded to Os Sierra I started getting errors that my backup was unencrypted. So, I removed the disk through TimeMachine, then enabled encryption and tried to select the back up disk again through Time machine but now it will not load. I get an error that says, “Problem Connecting to server “WdMyCloudMirror”. Server may not exist or it is unavailable at this time. Check Server name or IP address. Check your network connection and then try again”. I can see my MYCloudMirror in finder as shared. I can log into MyCloud as a user and I can log in to MyCloud Dashboard. Is there a fix for this or are we waiting on vaporware/firmware 2.11.153 from WD?

Hi, I would try to map the drive (not particular sure if it will work on OS Sierra).

Click on go then click on connect to server and when it asks for the server information type afp://drivename

I am having the same problem. I can connect all shares using finder, but time machine can’t connect to the time machine share. Funny thing is if I select another share that I store my movies and music, it can connect

Same problem.
Cannot connect it with finder, but connect server works.
i’ve tried:

  1. change the username
  • no help
  1. change the password
  • no help
  1. change the name of wdmycloud mirror
  • no help
  • now when i mount it via connect server it shows under old name, new name still will not connect in finder

Has anyone solved this?
Also Im on latest firmware.

Hi - I can connect my drive and map it (followed previous instructions elsewhere, no probs) BUT my cloud device (myCloud Mirror Gen2) appears as a shared drive NOT a device. I’m not sure what the difference is other than WD Utils doesn’t see it (as a device) and Time Machine doesn’t see it at all and wants me to look only for a Time Capsule (which I don’t have) so therefore can’t backup my Mac (also running Sierra). Can someone help this newbie out please?? Thanks

I have a big problem. I loose the connection to my Nas when I restart the modem. I have the latest firmware och may MacbookPro runs OSierra. I can’t connect at all after that I restarted the modem. I have also an iMac with OS X El Capitan and there are no problem. What to do?
I have also tried to restart everything from the beginning; modem, router, Nas och Mac.

The day after I wrote the above, the Nas return to the desktop. I do not understand anything. Today I switched to a different WiFi network, but switched back later. To my surprise, Nas once disconnected and unable to switch it on again. Does anyone have an idea how to solve the problem?