Temporary solution to TimeMachine Backup issues (fails after the first backup)

So, you have and EX2 Ultra and, after recent updates, your TimeMachine backups stopped and now your Mac says something like “original disk can not be found” or backups once, then fails with “the backup disk is not available”.

After a lot of ping-ponging with WD support I believe that I found the reason and (a working) solution to this problem.

First of all, let’s check that you have the same problem as I do. Go to Settings → General → Time Machine → Configure and set the limit all the way right (100% of disk). You might to restart your Mac, but if the backups are working with 100% of disk, then read below how to backup your Mac AND still limit the size of backups.

For those curious - the reason is that WD is using an archaic (4.9) version of Samba to build it’s firmware, and this Samba version is affected by a bug which prevents TimeMachine from working on ARM V7 processors - 13622 – fruit:time machine max size is broken on arm - which is, by coincedence, the processor EX2 Ultra is built around.

So, how to fix this until WD upgrades Samba to 4.12+ where this issue is no more present? See my instructions here:

  1. Go to TM settings on WD, set TimeMachine share to 100%, save settings.
  2. Remove all backup disks from TimeMachine on Mac
  3. Go to Users on WD, add new user (for example “tm”), set password. Open user “Quotas”, set size to whatever size you want to allocate to TM.
  4. (optional) - WD automatically creates a share with a name identical to the new user name - you may go to “Shares” and safely delete it
  5. Go to TM settings on your Mac, do “Select disk…”, select TimeMachineBackups on EX2, and then user popup appears, DO NOT select “Guest”, and log into with your newly created user (e.g. “tm”) instead
  6. Voila, backups work, backups are limited by “tm” user personal quotas, enjoy your buggybox.

(I don’t take responsibility for damage and / or loss of data, of course)

Cheers!

3 Likes

Hi @andrewtch,

Please check the article My Cloud OS 5: macOS Time Machine “Backup Disk Not Available” or Finder “Connection Error”:
https://support-en.wd.com/app/answers/detail/a_id/32003

@Keerti_01 , with all due respect, I have a feeling that @WDStaff is just ignoring everything which is written to them.

As I’ve written above TimeMachine works if size limit is 100%, and does not work if any limit is set - so this is definitely not a protocol error, this is a configuration error.

And yes, the error is caused by and affected by only one setting - TimeMachine size limit. This is repeatable (and basically very easy to diagnose - you need one EX2 Ultra and a Mac).

PS: And yes, it’s SAMBA
PPS: The article at the moment is a bit obsolete because Apple removed AFP support two MacOS versions ago and there is no way to connect via AFP (and TM automatically upgrades all the URLs)

2 Likes

Hi,

I appreciate that you have performed the troubleshooting steps.

Please contact the WD Technical Support team for best assistance and troubleshooting:
https://support-en.wd.com/app/ask

Yes I did :slight_smile: no help there and just the same links sent.

If you really want to help - can you please show my post to your firmware developers?

2 Likes

I have the exact same issue as @andrewtch.
Can recreate the issue on the fly by switching the MyCouldEX2 TimeMachine storage settings between 100% and any other value. It has only occured since the recent firmware updates. Not user error.

So, this is a reply from WD:

Use 100%, we don’t care, maybe we’ll fix it someday. Maybe.

Apart of that if you need to limit the TM size please use the method I proposed.

This bug caused by the firmware update is, to put it mildly, utterly unacceptable. I lost years of TM backups on my EX2 as a result (I had copies elsewhere) because the bug occurred as I migrated to a new Mac with Apple silicon, and could initially not figure out what had caused it. A quick note: I thought of andrewtch’s solution when I encountered the problem, but it comes with another drawback: the maximum user quota is 4TB, and I wanted 6TB out of a 8TB drive. So one can use 100% of the drive, or set a user quota of 4TB maximum. In both instances I was at least able to create a new TM backup…

Indeed. I’m looking into Synology because my data is much more expensive that the price of upgrade.

Me too. My device was wonderful working until WD deceided to program a new firmware while the devs have been drunk or something. Maybe they have fired the wrong people as well. I personally keep the disks from my current device and get myself a Synology. Looks like that one is working much better.
Current problems beside the known time machine bug with the latest firmware:

  • no more power plan. Device stays online 24hrs/day. No matter which setting is set
  • Device name can no longer be changed
  • even when the device is online, the web interface cannot be reached anymore

Sorry @WDStaff, you rendered good working devices useless with your latest firmware experiments.

thanks for your solution. at least a workaround now.

what WD is doing here, no service, no support, only standard replies and “open a support case” etc. → simply not acceptable.

they still haven’t reacted or offered a solution. this device was marketed as time machine compatible. there must be enough users out there who are sitting on a useless device now.

i’m close to selling this thing and switching to another brand, never never never ever buy anything from WD.

Switched back to my old TimeCapsule for now. as the workaround (guest access, limit to a 100% etc.) stopped working under 5.20.113 for me. It´s really a shame as the wokround did work under 5.19.117.

Now I´m getting “CIFS: Authentication for user [GUEST] has FAILED.” after the initial backup (which works fine) although everything is configured properly and as advised by WD. I´m also able to access the share in Finder and if I unmount the share and mount it again as “Guest” the error persists.

vielen Dank!!

Keine Lösung! Sie haben das Gerät und meine Backups Kaputt gemacht, und einen ganzen Tag meiner Zeit vernichtet. Das ist nicht akzeptabel.

Andrew, Western Digital owes you a lot of money! EVERYONE who owns an EX2Ultra and a Mac has this problem that WD ignores. This was driving me nuts, I was ready to buy an external USB HD to backup my MacBook.
You are the only one who provided a fix and I confirm it works perfectly.

THANKS A LOT!

NB: running MackBook Pro (2018 Intel), MacOS Monterey 12.3, My Cloud EX2 Ultra 5.21.104

If you look at the samba bug report, it seems like this originated with MacOS not being able to determine the correct size of the network drive and the alternate fixes were either to disable the max size option or to change the samba code. Synology is no better in this regard as they are still using samba version 4.10.18 as of 2022-03-24.

You can easily test this issue by using OMV 6 which is using samba version 4.13.5-Debian

 Louis 2019-05-06 08:54:17 UTC

Hai, 

I've gotten a report also thats this is seen on Debian 9, 64bit. samba 4.9.7 
I've ask the list reporter to update the bugreport here also. 

his report. 

MacOS can’t seem to get the size of the disk.

I’ve traced it down to this config option
fruit:time machine max size = 326G

Which results in

[Sun May  5 15:47:28 2019] traps: smbd[9658] trap divide error ip:7f8d722a84bb sp:7ffdf4e93cb0 error:0
[Sun May  5 15:47:28 2019]  in fruit.so[7f8d7229f000+1c000]

If I remove the max size option, all is well

Comment 8 Oleg Semyonov 2019-05-06 09:04:31 UTC

From the code:

	if (bandsize > SIZE_MAX/nbands) {
		DBG_ERR("tmsize overflow: bandsize [%zu] nbands [%zu]\n",
			bandsize, nbands);
		return false;
	}

it follows that when you have no TM bands yet (before the 1st backup), it will zero divide. And, as I said, this 'if' is useless when you operate with 64 bit values (it always will be less than uint64_t max value).

Removing both 'if' and adding type conversion should fix all reported issues and make max size option work. At least, it worked for me for both new and incremental backups.


It seems like this problem is still not solved by WD, is this correct?
I tried to set up a new device for a couple of days until I found this thread and it seems like my problem is described here pretty good.
Tomorrow I’ll try the 100% „solution“.

@uselessuser dunno if it’s fixed - never tried default config since I found the solution.

Good luck there, however “100% solutions” is to sell WD and by Synology )

Guy’s I have posted full solution as WA for all users.
Sell WD and buy some other NAS is not an option in case this is SMB protocol issue.
WD could return afp support (I’m really can’t understand why afp was removed) or revert SMB version to some other that could return normal disk size.