Timemachine stops working after update to FW 5.19.117

After the automatic update to FW 5.19.117, Time Machine stopped working.
Also I can’t connect via AFB to the Backup system - only smb is working.

I think I need AFP to get time machine to work.

Any ideas

1 Like

Apple File Protocol (AFP) is no longer supported on My Cloud OS 5 firmware 5.19.197 and higher.
For more information, please refer to My Cloud OS 5 firmware release notes

  • TimeMachine Backups must be reconfigured using Samba (SMB)
  • Connections to shares must be reconfigured using Samba (SMB)

My Cloud OS 5: macOS Time Machine “Backup Disk Not Available” or Finder “Connection Error”

Answer ID 32003

1 Like

All I get is this:

Not sure - Does it have to be public?

Same here, ensured to reconnect TimeMachine through smb. All other volume on the NAS connect properly, only TimeMachineBackup will not connect.
Opened a support ticket now…
Any help in between will be appreciated.

Hi,

I seem to have the same issue. Since the firmware upgrade on my WD, Time Machine has stopped working.

I am getting the following error message.

I have verified the username and password, and all correct.

Did y’all switch to SMB?

I think so (How do I make sure Time machine connects via SMB). All I can do is adding the one drive I see in the “select Disk” menu.

I can access the drive from the finder. And something else seems to happen:
When I create a new share and assign to time machine the initial backup completes, but then it never backups again and I see the following notification

If you mouse over the backup name in the “choose a disk” windows, the URL should show up and reads either afp:// or smb:// and the you know. If it shows afp://, remove the backup disk and then select it again, it should switch to smb.

Only the TimeMachineBackup share is made to work with Time Machine.

It does:
Screen Shot 2022-01-13 at 1.54.50 PM

And it did before - I am almost certain, as the initial backup worked.
When I create the share is there anything specific to watch for?

It is my understanding that the TimeMachineBackup share is set up with special settings for Time Machine to work correctly.

Can’t you use it instead?

I don’t have a share with that name and I don’t think I ever had

seems odd that I can choose a share for time machine

Oh. Maybe you are right. Seems legit. Let’s see what @WDStaff think…

1 Like

Same problem here. After updating to 5.19.117 it´s not possible to do any TimeMachne backups.on the native “TimeMachineBackup” share any longer.

However, as someone mentioned before, if I create a new share for backups (which is indeed connected via SMB), the initial backup on a newly created share works fine, it is also possible for me to do a second backup after that.

But after a reboot or sleep of my Mac mini M1, MacOS reports that the “Backup Disk is not available”. It can not be accessed via Finder. What I found out is, that if I disable the TimeMachine feature in the EX2 Ultra Settings, I suddenly can access the share via Finder again.

All the above mentioned only happens in relation with TimeMachine, no problems with the “Public” or “Recyle bin” shares.

Help appreciated, greetings from Austria!

Thanks Austin - yes, smb://mycloud…

Oh… Thought twice about this.
@petzi-baer I know why it’s failing. It’s because of the size limit you set… There is a bug that makes Time Machine backups fail, despite it was said to be fixed in v5.12.108 it is not I think (although I did not try with the latest firmware version… See: TimeMachineBackup works intermittently

Try setting it up at 100%. (I know it is a feature that we are all missing).

Thank you for the tip!

Turning off TimeMachine in the settings, setting to 100% and re-enabling TimeMachine indeed worked.

Strange though that the limitation worked in 5.18.117 for me as I had it on 1TB.

Were you using AFP back then?

Not quite sure, I think it was SMB already.

I can’t believe that AFP has been disabled. That doesn’t make any sense. We’ve been using the NAS here with a Mac in a team for years and have never had any problems. Since the update we can no longer access the NAS.

Please enable AFP again in the next update. SMB on Mac does not work correctly!!!

1 Like

Made sure to connect through smb, also from a second Mac. TimeMachineBackup is shown in the list of available shares but when trying to connect from Finder, same error message as posted by Foxward will pop up. Changing the backup volume in the TimeMachineBackup app doesn’t work either.
NAS drive is was updated to Mycloud OS 5 before. This only occurred now after the recent update without any changes to the drive settings.