Timemachine stops working after update to FW 5.19.117

What about the size limit? Did you set one?

Confirmed, set a limit to 3 TB on a 4 TB RAID. Same as prior to the FW update.

EDIT: Indeed, switching off TimeMachineBackups and then setting to 100% after switching on again resolved the issue for now.
I consider this a workaround, not a solution. Effectively, the size limit doesn’t work.
Thanks to @AustinForest for pointing this out.

I think that was it. Just weird that I didn’t had this issue before the update

Yeah.
Go complain on the topic I pointed out earlier on. This should be fixed for real.

So this is a bug right now. Limiting the share does not work any more. Hope this gets fixed in an upcoming FW release.

Make sure to have your voices heard. It’s been there since the beginning is OS5, was said to be fixed months ago and it’s not.

I will never buy a WD product again. I bought this device for my home office that uses exclusively Apple equipment. AFP is more performant on macOS than SMB.

REMOVING FEATURES FROM PRODUCTS IS NOT ACCEPTABLE. I did not buy a NAS with only SMB support. I bought a NAS with SMB and AFP support, which this company has now STOLEN from me through an automatic update.

I guess I’ll be giving my money to Sinology now.

1 Like

Hello everyone!
I found solution.
Download previous firmware 5.18.117 from link: https://downloads.wdc.com/nas/WDMyCloudEX2Ultra_5.18.117_prod.bin
From Settings > Firmware Update > Manual Update make a manual firmware downgrade with button “Update From File”.
Don’t forget to disable Auto Update on the same page!!
After reboot go to Settings > Network and enable “AFP Service”.
That’s it. :slight_smile:

1 Like

SMB is the default protocol since 10.9 (2013) and SMB is supposedly more performant. In addition, Netatalk, the AFP open source reverse engineered stack, has not been updated for years…

I guess all your Macs should be compatible with SMB isn’t it?

Thanks @gogsy7 - I have a different MyCloud nas - not the EX2Ultra. Do you know where I can find the correct previous firmware 5.18.117? Thanks.

Thanks @RalphW and @AustinForest - Setting TimeMachineBackups to 100% worked for me as well. Not sure if there is a different way to contain the size of the back-up space used on my MyCloud?

1 Like

Keep asking for it to WD… @WDStaff

Yes, good point - @WDStaff

Maybe someone from @WDStaff will soon comment here…

I did some testing and finally I’m back on FW 5.18.117. The space limit is definitely responsible for failing TM Backups but prior to 5.19.117 the backup service could (“secretly”) fall back to AFP (if this protocol was activated) … that is why I wasn’t aware of this bug till the FW upgrade.
I’m not willing to pile up possibly 8TB of TM Backups on my drive (I got four devices in the backup pipe), although I lost Cloud Access in the process because I can not reconnect to remote service after downgrading the FW (Error 500).

@WDStaff … please fix this!

2 Likes

Recommend you read the release notes. It does not mention AFP and the security notice mentions NetTalk…

So far “Connections to shares must be reconfigured using Samba (SMB)” does not work on password-protected folders. The error dialog states “There was a problem connecting to the server xxxxxxx”.

WD must know the number of macOS users. Feedback to managers this is a WD fail. Please send instructions that work for connecting or send a link to restore to the previous firmware edition.

1 Like

same here I bought EX2 series for TM backups and set a limit for the BU share to 7 TB(90%) to use the rest for other sharings e.g. with my kids - the last time machine BU worked on 10th Jan., FW was updated to 5.19.117 on 12th January. Today I upgraded MacOS to 12.1 which did not help. I removed the EX2 volume from TM and now I am not even able to re-add it.

I really need a fix (or want my money back, but I won’t assume that this will be an option for WD)

Same issue. The Time Machine share is defiantly a public share. I’m not able to access it via the finder or another method. I’ve turned time machine off and back on … no luck.

Set timemachine to 100% and the issue is resolved. Makes no sense, but Ok.

1 Like

Hi all. I’m soooo disappointed - I won’t buy any WD products. Yes, the RED Drives are good, but this NAS is a bad joke. I have three of them, I was always happy. But since the latest FW Update 5.19.117 SMB it won’t work anymore. I did moved to SMB (3) successfully in 2020 - everything was good, but with the new FW nothing is working anymore… (re: TimeMachine). I grabbed one of my three devices, did a reset and tried again. Doesn’t works anymore.

I contacted the support, waited 45 minutes for a free chat agent. Result: Links to the knowledge base and community I already used and tried… I told the agent, opened a ticket. After one week the reply: exactly the same link as in the chat. Ridiculous. They don’t know what they are doing with this frickin’ OS they put on these (in general good devices).
Very bad, one of the worst customer experiences I had.

@ tostor001 Yes, you are right. The problem is in fact that I’ve read the release notes upfront, before the update. I’ve seen the SMB note and I was happy that I already moved over to SMB last year. I did the update, after that TimeMachine is not working properly anymore. When a customer is doing exactly like they should, the stuff really needs to work. But WD maybe need to cut costs in testing… this is really a silly situation they moved themselves into.