TIME MACHINE still not working after Firmware update on MyCloudEx2 Ultra

Still waiting for a working solution from WD. Even still waiting for a statement about this.

I had two Macbooks doing their Time Machine backups to a Ex2 Ultra. Not working anymore. Not looking for somekind of temporary workaround. I need a quick and easy solution, a solution coming from WD.

I might throw out the WD product soon and buy a competitor’s product and never ever come back to WD. Any ideas what would be a good non-WD replacement NAS?

Hi @mickn,

Apple File Protocol (AFP) is no longer supported on My Cloud OS 5 firmware 5.19.197 and higher.

For more information, please refer to Answer ID 32003 My Cloud OS 5: macOS Time Machine “Backup Disk Not Available” or Finder “Connection Error”

thanks, but this does not help unless you tell me now, how i can continue backing up two Macbook to the MacCloudEx2Ultra.

you referred me to “Reconfigure Time Machine Backup” document where it says: “Ensure the Time Machine Backup Maximum Size is set to the default of 100%.”
→ I don’t want 100%. In the past I had this set to a lower %.

Also, again, I need clear and precise instructions from you as to how to continue backing up two macbooks to the same NAS. Two different shared folders were used for this. Is this still possible?

Awaiting your help.

1 Like


I appreciate that you have performed the troubleshooting steps.

Please contact the WD Technical Support team for best assistance and troubleshooting:

No, Keerti, I won’t contact WD Technical Support team for “best” assistance.

Instead, you tell them to come here and post a solution for the problem. The problem has been described often enough now. There’s no need for individual support. There are thousands of users with the same problem so the least you guys can do is come here and post a proper and easy solution for everyone.

It’s unbelievable what you guys are doing here. I bought this worthless device to use it with Time Machine. It was marketed as being capable of this. A more or less forced update simply made it useless. It is not appropriate to demand I contact tech support and invest more and more time just to find a solution.

You tell them to come here and post a solution for these problems:

  • How to set up MyCloudEx2 Ultra for properly working with Time Machine
  • Without losing past backups
  • MOST IMPORTANT: How to back up two separate Mac OS computers to the same MyCloudEx2 Ultra

thanks four your service, which on the other hand is the least you can do.


so where’s the solution?

how do i Time Machine back up two macbooks to the mycloudex2 ultra without losing older backups?

1 Like

Hi, I also want this: 50% of Space for TimeMachineBackup and 2 Macs to the same NAS. For the moment it only works with 100%. But I don’t know, what happens, if I put a big file on one of the other partitions. Would TimeMachine reduce his/her space?

they don’t even react to customers’ complaints.
that’s how they treat customers at wd.

i think the size of a time machine backup can be limited - haven’t tested this yet

If AFP is no longer supported, what do I use for TimeMachineBackups on a Mac running MacOS 10.15.7 or MacOS 12.2? I have already submitted a ticket to WD Support. They said that run Disk Utility on the WD MyCloudEx2 Ultra which can not be connected to because AFP is not supported. (Totally run around here). So I have 8GB anchor that is setup for Raid so I have access to only one 4GB HD. How do I run TimeMachineBackups?

well i’m afraid they give a sht here about our problems with their product

any solution from those wd-losers yet?

Nach einer neuen Auswahl des Share in Time Machine und anmeldung mit demselben User wie im Finder und entfernen der Passwörter im Passwortmanager und Neustart der NAS hat das Backup wieder funktioniert :blush:

Same here (el capitan). Time machine can’t find the disk on EX2 Ultra. Finder can see it but time machine doesn’t. I followed the steps to mount the server folder with smb (finder/go/connect to server…) but nothing: still doesn’t work. I don’t know what to do…

I had the same problem as everyone else. I’m a brand new user and all the usual time machine issues out of the box (Catalina 10.15.7). Tried many remedies I found on web sites but today one thing solved my problem

Reconfigure SMB protocol using simple terminal command!


Hooray! First backup happening as I type…
Good luck everybody

Spoke too soon! First backup was fine, now getting error messages on subsequent attempts. So now a different problem that everyone has - think I’m just going to get a refund and try Synology. Bought the Ultra because of Mac support but it’s clearly broken in so many ways…

I don’t know if this can help, but read here: