Admin Password

Dear All.
I have a brandnew My Cloud Mirror Gen 2, my first NAS.
I installed it some hours ago. When I tried to connect to it, it asked me a password as “admin”. I tried blank, admin, Admin, but it doesn’t work. What is the correct Admin password?
I tried also resetting the password with the reset button for 40 seconds, but nothing to do.
Can you help me?

Should be username “admin” and no password at all initially.

The reader button at the back should set it back to that if you PSG it with a paperclip or similar until the MCM reboots.

Thank you for your answer.
I tried to use admin and no password; I tried also with reset with paperclip for 40 seconds…
I tried to switch off the mycloud and the router.
But nothing to do.
In Windows File Manager i see the Mycloud, but in the Mycloud setup I don’t see it

How are you trying to connect to it?

If you access it via a web browser can you get to the dashboard that way? In Windows it should be at http://wdmycloudmirror if I remember correctly, unless you have renamed the drive (which won’t be the case this time as you haven’t got that far yet).

I have the same issue. A brandnew MyCloud Mirror. I’ve run through installation process. Everything work. I can see the device on my Windows Desktop. Either Sync and Wave is working. On my iPad I do have access also. I can upload and download files.
The only problem is the dashboard. It is requesting a password for Admin user. I tried “admin”, “Admin” with and without password. I tried also the same password Windows is asking when I connect to MyCloud. Neither works on the Dashboard.
What is the right password?

I created a new user. When receiving the email to create a password I was logged in automatically. After logoff I wasn’t able to log in again. Neither User work, neither with or without password.
I can log in with both users via internet

I can’t log into the dashboard with any user:

Can anybody help?

Hi did you get this solved. I have a brand new My Cloud Mirror and same issue.
I can access via web browser but cannot access via windows PC.
Tried admin and Admin
Tried a reset of device by inserting paperclip into rest button on back
still no access

You have to reset with a paperclip for 45 seconds and then try again

Ok… same issue here. Brand new MyCloud Mirror Gen2. Apps and web browser are fine. Trying to access dashboard with user: admin and no password gives me consistently “user name or password entered is incorrect”.

Tried the paper clip trick (5, then 10, then 45 secs…), it does reboot, but same results.

Clearly something is wrong here. Any assistance is welcomed.

Just an update, resetting the drive with the pin for 45 plus seconds, worked.

SAME here… i setup and reset a few time with no results. still cannot go in the dashboard. help!

Did you try reseting with the pin for 45secs? (or a bit more…)

I confess that I tried two times before it actually worked…

GOT it to work… tried couple to times.

press the pin until the unit reboot… ( approx 45 sec ) . the unit will reboot 1 times and reboot the 2nd time then all will be back to factory setting.,

i ran the wd mycloud setup to set the username and password.

All files are still there…BONUS… old private folder will be open for public viewing…