Newbie needs help please

Hi all,

I am a newbie to MyCloud Mirror (only delivered today) and I appear to have gotten myself in a bit of a mess already.  I have installed it onto my network as instructed, and installed the relevant software onto my PC;  I then added a second user (my other half) and then got a message to update the software which I duly did.

I then went into the Dashboard and noticed that there was two users admin and my Mrs, so I changed the admin one to my name - but chose not to set a password at the moment until I got myself a bit more settled with it.  Within a minute or so, I got a message saying that the user had timed out and asking me to log back in - - I have tried logging back in with my name, (with and without the password that I set my cloud account up with)  even tried logging in as admin, and again - no luck.

Can anyone tell what I am doing wrong, and is there a sort of ‘master reset’ where I can start over and get access to the dashboard?

EDIT - I have just tried accessing the dashboard as my other half and it lets me in to a limited dashboard, but I cannot access with admin rights.

There’s a reset on the back of the device - the little hole just above the USB ports. See  here for more details and a pic.

Push that with a paperclip or something similarly narrow for 5s and the device will reboot and the dashboard settings will reset to default so the original factory admin login credentials will be restored.

Personally I’ve left the admin account exactly as it was (aside from giving it a unique password) and then just added user accounts for all my family plus a general media access one with suitable access rights as appropriate.


Thank you :slight_smile:

I did that, but it didn’t seem to work - perhaps I didn’t press the button in long enough.  I will give it another try.

Quick note of thanks - it appears that it had worked, but it hadn’t restored the username to admin, instead keeping it as my name.

The only version of my username that I didn’t try was all lowercase - I spotted it in lowercase in the MyCloud program (clicking the selection button at the top right corner), so thought I would give it a shot, and hey presto I was in :slight_smile:

Managed to set up streaming within seconds, and my Mrs is sat watching a film on it now via the PS3 - lightning quick at loading too, so very happy indeed.

No doubt I will be back over the coming days for more help.

Thanks again