Absurd connection issues

My EX4 states, under services, that Active Directory is OFF.

My Active Directory shows that the WDMYCLOUDEX4 is available through Windows Explorer and I can visit every folder thereon over the Network from any computer.

There is no Global Access available except that, under Cloud Access and my username, it is stated that Cloud Devices are connected and a Relay connection is established.

The very reverse of what I expect has occurred. This is ridiculous. (My Seagate, naturally, is working properly, so it’s not the internet!)

I have opened a ticket with WD about this, because it is so unbelievable and I really think that having paid a substantial amount for the EX4 I should expect it to work. Wouldn’t you?

A change for the better, with no reason discovered.

I have Cloud Access, and I have Active Directory access, but the latter works and is NOT turned on.

This means that, having cured a Windows problem to do with User Credentials, all of my computers now have access to the EX4, without having to add a username and password!

The Cloud Access was set up with the normal procedure, and works.

So, I have no clue why it works, but it does, just as my Seagate 2-bay NAS does. Where the logic is within the firmware is not known to me.

If you are simply accessing the EX4 through Windows, you don’t need to have Active Directory on to access it over the network. Since Samba service runs by deafult, you should be able to access the EX4’s shares as long as usernames match between the EX4 and the Windows PC trying to access from (and preferably passwords match too…but they don’t have to - you will be prompted for password if they don’t match). All this should work fine without having to turn on Active Directory.

That may very well be true, but it has only worked after the recent firmware upgrade. Certainly not before that, and I had major problems with AD, even if Samba was running.

Only lately has everything worked.

Nothing is perfect!

Every time I reboot a computer the Seagate NAS is there under Network and can be opened straight away.

Every time I have to open Control Panel/Users and go to Manage your credentials and click on the EX4 to remove it from the vault. Only then can I open the NAS under the Network icon in Windows Explorer. Given the number of times one has had to reboot a Windows machine of late, this becomes a chore when one has more than a couple of computers.

The main AD Server stopped showing the EX4, and, of course, I can’t discover why. One of my Win7 boxes was rebooted to fix the out of order update (Heartbleed), and stopped showing the EX4, which I could only open by double-clicking the icon in Explorer/Network.

This problem has NOT been cured by the latest WD firmware update.

Now what?

I had a power outage in my area today for several hours. I have done nothing to change the parameters of my EX4, except that on only one computer, when the power was restored, did I have to go to Control Panel/Users/Credentials to remove the EX4.

When I restarted all of the other computers the Windows Explorer/Network immediately showed both NAS objects that I own (the Seagate and the WDC).

I can access all folders on both NAS objects from all of my computers!

I have no idea what happened, but I’m glad it did!

Now then, even if the dashboard tells me I’m not connected via Active Directory, something peculiar has happened.

Following the latest Windows Update, which those who know realise occurs not quite the middle of every month, I have discovered that under Control Panel/User Accounts/Manage Your Credentials there are changes. The EX4 is not always under Windows Credentials as it once was, but severally is written under Generic Credentials: I don’t understand why it differs between machines, several of which are the same make and model.

Not that the changes are identical for each of my work stations, but all I have to do now is click on the EX4 icon under Windows Explorer/Network and enter the username/password. Every computer is able to connect directly to the EX4.

Note, however, that the Seagate NAS always opens by simply clicking on it, so things aren’t perfect, but are now eminently usable.

Updated to 1.03.39, and matters have not improved.

Firstly, I have, at login, ticked ‘remember me’. It won’t.

Secondly, and this is major, the ability to open using a Windows Network icon on the Explorer list is now impossible. I have to go to Windows Explorer, Network, and click on the EX4 icon, and it will open then with its IP address. Emptying the User Credentials vault makes no difference now, the EX4 won’t open.

Of course, the Seagate opens as it always has, just by clicking the Network icon.

The ability to concurrently use Active Directory and Global Access is still not possible. Why ever not? It is possible with all other NAS manufacturers offerings.


Networking not accessible notice, which used to be stopped by emptying credentials vault.


Log in, where before the latest update, the password was indicated by dots. Not even there now, although Remember Me is checked.

Network on Active Directory, Windows Server 2008 R2

Control Panel, Users, Credentials, where is the EX4, opened using the icon in the following image.

I have to double click the WDMyCloudEX4 icon under Storage (2), which opens another Explorer, whereupon I can open every icon on my network. Note that I don’t have to open the BA-3922AD the same way, since it opens normally (see a previous image above)

Please respond if more info needed.

With that, I can tell you WHAT, but I can’t tell you WHY.

In the case you’re seeing where the “Network” tree doesn’t work or isn’t fully populated, but clicking the STORAGE icon works:

The SMB Master Browser on your network has failed and isn’t responding to “browse” requests.

I just had the same problem this morning after rebooting my QNAP NAS yesterday (which is configured to be the Master Browser.)

When the QNAP went offline, another device on the network should have assumed the browser role – but nothing did.   I have eight “potential” browsers, but none of them worked.

Windows had cached some hosts under the “network” tree, but when I clicked them, I got the same erorr you’re seeing.

I don’t know why it happened – the election of another master browser is normally a simple thing.  But NONE of my QNAPs, Windows boxes, WD boxes, or otherwise did it.

I had to restart my QNAP again, which then restarted the browser election process, and now my WDTV is the browser and everything is working normally.

I wish I had taken some screen captures like you did while I was fixing it – they looked pretty much like yours.

Thanks for that, and to add:

Each of my computers acts peculiarly, which, being Windows is a normal behaviour, isnt it? The main computer for me is Gallowglass, which won’t open one network computer, Cornwall. That one will open Gallowglass and, when I open a find image with the WD Support, automatically opens the folder on Gallowglass to choose the item.

The situation on my other computers is that the Seagate opens with one click, and the EX4 now opens by double clicking under Storage. As far as I can determine, nothing can be found that I can obviously state is the error or whatever fault.

Typical networking, typical NAS.

Paul I had the same issues after installing the update.

I couldn’t connect at first but a simple reboot of my pc resolved that after updating the EX4 firmware. I felt kinda stupid it was that easy to resolve after trying to troubleshoot the problem for almost an hour.

I’m still having trouble with the remember me option for my login credentials.  Support told me to manually install the firmware update and see if that resolves the issue. I will try tomorrow.

Also the stupid thing jumped back into Relay mode again for some unknown reason as well as it won’t go into standby as it should prior to the firmware update.

An improvement: for the past few restarts on the main computer, I simply have to wait until the two NAS drives populate the Windows Network section of Explorer.

Then, the Seagate opens natively, and the EX4 opens a username and password box. Filling that in, and NOT telling it to save, enables it to open the folders, and to do it again the next time I have to restart.

Therefore, the latest firmware is working somewhat better than before.