500 - Internal Server Error

Attempting to log in on my browser, that message arises.

I can access the drive over Windows Explorer. 

Anyone know what this is caused by?

That’s a generic error code returned by Apache when it can’t be more specific as to what’s gone wrong.

Unfortunately, if it doesn’t correct itself, there may not be anything you can do about it short of doing the reset procedure outlined in the manual and see if that corrects it.

Fixed it only by turning off, and restarting the box.

Don’t know what the cause was, but was trying to set up a share, and that shouldn’t do it, should it?

I got that same message but under a different circumstances:

I had adblock enabled and wanted to disable it for all web pages for EX4 so I click logout and disable adblock for EX4 site and then went to do the login. After entering password, I got Error 500.

Only way out was to shutdown the EX4 from its power button and then restart.

Someone knows what causes this?

Does EX4 has some stability issues that need to be worked out?

It happened again rather unexpectedly.

I was logged into the web dashboard and clicked logout. it went back to the login screen.

After a while I entered the password into this same login screen and press enter the next screen was totally blank.

Waited for a while but nothing happened so tried the refresh button of the browser (Firefox 25.0.1) and got the dreaded “500” error.

I have data copy currently going on and don’t want to just restart the device to gain access.

Anyone know how to have the web server restarted without power down the device and restart?

Trying to answer that, I find I was wrong – the EX4 doesn’t run Apache — it runs lighttpd.

I haven’t found a quick way to restart it just yet…

Happened again just now, on all three browsers that I am using. Only one, Firefox, indicates the 500 error, the others simply state, both Chrome and IE, that they cannot reach the page.

This is becoming ridiculous. Does WD want me to buy the Seagate NAS???

Yes, it is very annoying to have interrupt the data copy process to reset the device to gain access to the dashboard.

at least can someone provide a command or two that we can use after opening a SSH session into the device to help restart the web server on the device (provided a SSH can be started, that is).

it happened again.

Error 500 trying to access the web dashboard.

The only way out was to hard restart the device.

This is getting from annoying to ridiculous.

Can someone tell an easier way to gain dashboard access without a need to hard restart the device?

I think WD must address this issue in the next firmware release at least.

I’m begining to regret my purchase of the device.

Should have looked at the 4 bay NAS systems offered by synology instead.

True, I have thought about an RMA, but I’ll wait to see if what will now be January (?) for the proposed update that should correct the AD and web/cloud User disaster. I thought of Seagate, which has a version of both the EX4 and the My Cloud.

I have not had a 500 after the second one, but I have not been able to change anything to what I need in the User category. Data transfer is easy, however.

I have had this happen a few times as well. Typically happens when the server is busy (transferring data) and I try to log into the dash.

I’ve bumped up the dash timeout to 30 minutes (from the default of 5 I think). This has helped as I don’t need to try to log back in as often.

It is a PITA. I agree. 

what method are you using for data transfer?  I want to know the fastest way as I have over 4TB to load on to the ex 4.

I’m using win explorer. Not having any luck getting data moving quickly over my gigabit nw. Have a support ticket in right now…

  1. Having HIGH CPU utilization

  2. Typical speeds are 7-10 MBs. New giga cables, new router, new switch. Nothing helps. Not sure exactly what I’m missing… 

I did transfer a boat-load of photos and videos over so MAYBE that’s the high CPU utilzation issue? Wondering if that in turn is slowing down the write speeds? I don’t know.

I definitely was expecting more though. I see people getting 30-50 MBs and I’m jealous :slight_smile:

I have been getting the “500 - Internal Server Error” frequently. It seems to happen after a it spins down to “standby” mode. When it come back the server goes dark. Rebooting will bring it back, but ACK! how annoying. I would like to know if this specific to my device or something that may be corrected in a firmware udpate because right now I’m regretting that I didn’t spend a little more to get something more reliable. I’ve already had to RMA one fo the HDDs that was DOA.

It does not happen for me after it comes back from standby.

I can access the web GUI with no issues, even if it was in standby.

it did however give random 500 error when accessing the dashboard.

Have not seen this happen since upgrading to the 1.02.25 version of firmware.

Do you have this latest firmware installed and still have same problems?

Thanks kk -

I do have the latest firmware… but error 500 still happens.

And I’m not certain it’s related to standby mode, it could be coincidental. At any rate, the web interface is consistently going 500 and it drives me nuts having to reboot it all the time.

Also, the CPU is basically locked at 100% and everything is super slow. I disabled the DLNA server because it seems to rebuild the entire data each time you reboot – and that takes hours.

I am really not digging this EX4. My old QNAP was slow (even slower than the EX4), but at least it was reliable. It scares me to trust all my data to this flakey device. I hope I’m just overreacting.

When you can access the dashboard, did you check the processes that are eating the cpu?

it might just be thumbnail and media indexing processes that will take a while to scan through all your uploaded media, even spanning days, depending upon how much you uploaded.

Thanks kk

The process using the most CPU is ‘convert’ (currently 99.8%)

Do you let the web dashboard timeout after an inactivity period or you always click logout once you are done accessing the interface?

just trying to see if timeout disconnects leave the http server in a inconsistent state that causes it to throw 500 error.

Really appreciate your help kk.

Sometimes (but not always) I do let the dashboard timeout. At which point it reverts back to the login screen.

This morning the EX4 took several minutes to load the login page, and accessing it via the file structure was equally slow. Maybe it was in standby, but it has never taken that long to “wake”. As soon as it came back the CPU jumped to 100% thanks to the ‘convert’ process.

At the moment I am down one drive in my RAID 5 – the WD Red that shipped in bay 2 continued to fail after three attempts to reformat it. I’m awaiting RMA info from support. I don’t know if being short a drive puts any additional stress on the CPU for some reason.