CPU Spike at 100%

To date, I’ve only dropped about 20 GB of data on my Raid 5 array of 8 TB.  I noticed tonight that the CPU is spiked at 100% running some sort of image thumbnail generation software on images contained in the data that I have dropped.  And I haven’t even dropped that many pictures yet, and that was two days ago.  What is up with these processes and can they be disabled?



Hello flashfearless,

Does the drive still doing the same?

Have you tried resetting the device?

Yes I rebooted the device.  It’s not that the disk is showing 100% busy, the CPU in the unit.  When I check the processes running, it’s always the wdphotodbmerger process which is a pig.  I’ve heard other forums mention that the task that this thing is trying to do is build thumbnails for viewing in the apps which run on mobile devices.  I could care less about thumbnails and I would like to disable this process.

My EX4 has started doing this also.   No disk activity.   Mostly wdphotodbmerge uses 100% of the CPU.   Periodically wdmcserver claims 50%.

How can these be turned off?   It’s been like this for a couple days now & I barely have any pictures on the drive.   Mostly just PC backups.

– Ian

Same problem here - I have the diskless filled with 4TB Reds on Raid 5, over 300,000 files @ 5TB. After I got all that stuff copied to the ex4, cpu stays at 100% (wdphotomerge and wdmcserver) and never goes down, write speed crawls to 5MB/s, read seems normal. I’ve restored firmware, rebooted and I can write over 30MB/s for the first few minutes and then it drops again.

I also tried reformatting to RAID 1 to see if that might play a role.  It did not.  Still spikes at 100%.

Copies from Windows NTFS file systems were very cantankerous, BTW.  Many errors, many files skipped and I had to redo many directories.  Contemplating sending this unit back.

There’s a system log that’ll tell you some stuff about what wdmcserver is doing.    It’s at


Mine only starts when the file system is changed (right now it’s doing it every hour because Windows 8 is doing file history backups to the EX4, but prior to me starting that up a few days ago, it went WEEKS without ever doing anything.

My CPU right now is at 8%, and wdmcserver and wdphotodbmerger processes are both 0%.

Same story here… it’s ridiculous. That is, unless it is supposed to happen and if that’s the case - it should be mentioned.

I see all sorts of variation with mine. Granted, lots of files added but 5mbs?? Same story here. It is painful.

So… what’s up WD?

Tony - how do I access that system log?

Are you saying yours sat for weeks at 100% or the other way around?

RobStach wrote:


Tony - how do I access that system log?


Via SSH.

After about 3 days, my drives eventually went idle.  Still not 100% sure I am happy with this unit.  Performance could be better and it could be more compatible with comparing directories using Microsoft Sync Framework when the source drive is NTFS formatted.  IE, Microsoft Sync Toy gets hung up trying to compare my PC folders to the share folders to make sure that I have replicated the contents.  I’m not going to delete the files from my PC until I am 100% positive they are all there on the share folder.

RobStach wrote:


Are you saying yours sat for weeks at 100% or the other way around?

I’m saying mine sits for days at a time in Standby mode.

Once you get over that hump period (in my case like 3 days), yes Standby Mode will come your way.

Thanks so much for all of the info guys… really appreciated.

Today it looks like it is starting to calm down. Still plenty of spikes up into the 99% area but it looks more like an EKG of a healthy person rather than someone having a heart attack at this point. I’d guess if I had to average it the numbers would be mid-50s right now.

So… maybe everything will be okay.

Don’t get too bent out of shape on CPU utilization.

Any process that doesn’t wait on some external resource will ALWAYS use 100% of the CPU.

Only if the process comes from Adobe or Oracle do I see that kind of behavior. 

flashfearless wrote:

Only if the process comes from Adobe or Oracle do I see that kind of behavior. 

Then you haven’t been doing much. :wink:  A process that doesn’t use 100% is not utilizing all the resources available to it.  

Handbrake, ffmpeg, batch image processors, etc. for example, use 100% of all six cores of my CPU while they’re running   If it didn’t, it’d take proportionately longer to do their jobs.

Okay … I’m going on about 10 days now. No rest in sight for my drives. Something HAS to by wrong. Right?

CPU @ 100%. Convert process taking most of it. Stays pinned most of the time but will occasionally fall off but then right back up.

Am I over-reacting or is this normal?

Here’s my media snapshot:

I’ve been a developer for 29 years and have been very successful doing so.  I would consider anything running at 100% CPU a bad apple and I would kick it to the curb.  Anyone who develops their app to behave in this manner should be kicked in the nether region.

I hear your point. To be fair, I’ve been reading similar reports on other manufacturer’s NAS drives. 

My real frustration is the lack of understand or information as to what is considered normal…  I too feel like a CPU pegged @ 100% or drives that are constantly spinning can’t be a good thing. If this was normal; why would there even be a sleep mode?

Some simple math showed that even if the convert process was taking 1 minute per image, the process should have been complete in 8.7 days. Granted, other things were happening but there is zero information available as to what to expect.

I submitted a ticket to WD which went without a reply so far… that was over a week ago. Not acceptable - especially when you pay a premium price for a product.

In the process of moving everything back OFF of my NAS. What’s funny is that the CPU usage has dropped considerably since I’ve started moving files. I did turn off media streaming and itunes as well so that might have helped.

From what I can see there is no way beyond SSH to see where something might be hanging up. I’m not skilled enough to go there yet. Anybody have a link to a decent how-to on SSH?

I’m far from an expert but I am willing to learn - provided that I can get the information. Even a list of what each of the processes are would be nice. Then I could at least get a clue as to what is going on…

All part of the learning curve I guess!

While I am at it…

I see that another manufacturer provides desktop software that will offload the CPU intensive processes (like generating thumbs) to the PC prior to or during upload (not sure which).

Does WD offer anything liket that? Sure seems like it would be a tremendous help from an efficiency standpoint.