Windows 10


I have been using a WD live hub with windows 7 with no problems.

I have an external Drobo 5S which is shared and worked fine until I installed windows 10, now the WD Live Hub can only see shared folders on the internal drives but not the external Drobo using USB 3.0

I have verified the Security settings under advanced - effective access windows says that my user has access, but WD will not see the shares.

Has anyone else encountered this issue?

Hello and welcome to the WD community.

Try to take ownership of the folders to see if this helps out, i have Windows 10 but have yet to try this. Lets see if another user can help you with some tips and information on this matter.


Thanks for the tip, but ownership of the folders was something that I thought might have helped too, unfortunately I still could not see any shares on external devices. Tried setting the ownership of the folders to SYSTEM and my Administrator account.

Also tried disabling my BitDefender firewall, no change.

i know zilch about Windows 10 … but does anything in this link help ?

Same problem here. It’s not just the RAID box, it’s any external drive. I have four, and I’ve put simple shares on them that are readable by another WIn10 machine, but none of them are seen by the WDTV.

Nor are they visible from a Samsung Tablet in either Astro or ES File Explorer. The most likely suspect is the Win 10 SMB facility not working with external drives. Perhaps a policy setting?