WD TV Live does not see shared windows USB drives that are connected via hub

I have several external hard disks on my desktop PC. It is Windows 8.1 by the way.

Too many external hard disks in fact to connect them all directly to the USB ports on the PC.

So I am using hubs (USB 2.0 and 3.0, the 3.0 is even self-powered with its own power supply).

All the external drives are self-powered too.

All drives are properly shared (no limitations, everybody in my network has access). And all other PCs and Android devices on my network can access these drives perfectly via the wi-fi network.

But not the WD TV Live. It obviously sees only drives that are connected directly to the USB ports on the PC. The same drive is visible, when connected to a direct port, and becomes invisible to the WD TV LIve when I connect it to a hub (although it is visible either way to all other devices on my network). And it becomes immediately visible again, when I connect it back to a direct port.

Is there a work-around, please ? What is causing this issue ?

Update : well, the Android devices can see these hub-connected drives, but cannot access them.

When trying to open the visible drive I get an error message that the login failed, and that I should check the SMB server and service (well both work, as other Windows PCs can access the drives), the IP address or the firewall.

I have not found any corresponding elemnents there yet either.

But the access to the directly connected drives works perfectly.

Obviously Windows 8.1 is blocking any non-Windows access to the hub-connected drives.

Why/how is there a difference, and how can I fix this, please ?

Well, nobody offered any opinion so far, but I was able to solve the mystery.

It is all about the old IPRStackSize of the LanmanServer (Windows NT is greeting us again).

I was taken off, because access seemed basically to work (at least with Windows machines).

But the Windows 8.1 event log then told me very clearly : event 2011, irpstacksize not large enough, please increase.

This event occurred whenever I tried to access the shared drives from my Android devices or especially from the WD TV Live. The only difference netween these 2 systems was that on the Android devices I could at least see the drives (but could not really open them), while the WD TV Live did not even boither to show me the drives.

Now, I have no clue about the actual limits for the IRPStackSize in Windows 8.1 (the values changed from Windows version to Windows version). So I finally used the limit I found for older Windows systems : 32 (x20).

And it works now like a chram as it seems.

By the way - I found stories about older Windows systems, where people increased the value to 20 (x14). So I tried that value first. With the result that I could not access any drive from other network units at all. So, the default value for this in Windows 8.1 must be even higher than that. I don;t know what it is, but 32 (x20) is obviously higher.

Long story short : it is a Windows 8.1 (possibly already Windows 8) problem. And it can be solved by creating manually an entry in the Registry to add the IRPStackSize parameter with the higher value (as you know, when this parameter is missing, Windows uses a default value, which is obviously too small for drives connected to a hub and accessed by any kind of Linux systems.

I still don’t have a clue, why the access request by a Linux based system requires obviously more stack size than a request by a Windows machine. That is still something that makes me shake my head.

Here a little procedure copied from Windows NT solutions :

  1. Run regedit.

  2. Navigate to the following key:


3. In the right pane, double-click the IRPStackSize value.

  1. In the Value Data box, type a value that is larger than the value that is listed.

If you created the IRPStackSize value using the procedure described in step 4, the default value is 15. It is recommended that you increase the value by 3. Therefore, if the previous value was 11, type 14 , and then click OK.

  1. Close the Registry Editor and restart the computer.

If the problem persists after you complete the preceding procedure, try to increase the value of IRPStackSize even more. The maximum value for Windows 2000 is 50 (0x32 hex).

NOTE : If the IRPStackSize value does not already exist, use the following procedure to create it:


In the Parameters folder of the registry, right-click the right pane.


Point to New, and then click DWord Value.


Type IRPStackSize.

IMPORTANT: Type "IRPStackSize" exactly as it is displayed because the value name is case-sensitive.