WD TV LIVE shared folders issue!

Hello everyone,

I installed windows 10 and had that issues with password but it’s solved but now I have a new issue with folders I share on my network !

I’m sharing folders from my hard drive on my tower and 3 external drives.

In total I have something like 7 or 8 folders shared but only 3 shows up and the others don’t shows !

The 2 folders on my tower hard drive shows, got 2 folder on a same external hard drive but only one shows the other not and the last folders from the 2 last external hard drives don’t show either !

Didn’t had that problem before.

I’ve stopped the sharing and then shared again but it don’t show on the WD TV LIVE !

Any one knows how to fix that problem ?

Little rectification, it’s all the shared folders that are on external hard drive that don’t show !

Hi there, welcome to the community.

Have you tried resetting the media player? Is it on the latest version of the firmware? How did you share the external drives?


Thx for the welcome, the firmware has the last version when i look for update.

when I share a folder from my internal or external hard drive I right clic on it, propeties and then I clic on share and hit the box to share and apply.

And I see the folders but now that I installed windows 10 the WD TV LIVE only show folders from my internal hard drive but not from external hard drive.

Did a restart but not a reset.

Right-Click on Folder

“Share With”

“Specific People”

“Everyone” should be in lower window

Reboot all devices

hello I have same similar problem with my wdtv live,

I am on windows 10 pro and my wdtv is on latest firmware. I also have an freenas server.

so when I go on video and try to get windows shares i see only my freenas

so some body know how to fix it. I don’t think ms change somethin in share parameter can block wd tv

or do you know if an new firware will be release soon?

Thank you

There is some good advice here:


Hello again,

so now my problem is fixed. I don’t know how

Hello again, I fixed my  problem, but I don’t know how.

I reboot my computer, router,switch, etc. one thing I know, is I haved also problem with my freenas, no computer can’t see it on network. And if I try to reach it by is dns \freenas I got error but with is ip no error. so I reboot my freenas, and now everything  work fine.

maybe my frrenas push wrong dns to my router and alol compurer and my wd tv  was confused.

so thank for your help