Windows 10 shares fix

#1

Hello guys… Today I installed windows 10 and for past few hours I was trying to get my shares to show up like it did on WIN 7… after endless searching and trying this finally fixed it for me and now I am able to browse my shares via explorer :]

  1. Win+X -> Control Panel->Network and Sharing Center->Change Adapter Settings
  2. Right click on the Network Adapter->Properties
  3. Click to select Internet Protocol Version 4 (TCP/IPv4) -> Properties ->Advanced->WINS
  4. Click to select “Enable NetBIOS over TCP/IP” then click OK.

Then it took few moments and I was able to finally get my stuff :]

Hope it helps you as it helped me :]

4 Likes
Windows 10 & WDMyCloud not a happy pairing!
Windows 10
Backup smackup
#2

Hi there and welcome to the WD community

Thanks for sharing This information with the community, hopefully this will help other users with a similar situation.

#3

Thanks that solved the problem

#4

Just wanted to thank you.

I couldn’t acces my folders after upgrading to Windows 10. It would work very seldomely. I tried this fix and I now have access.

Thanks!

#5

I wish I could have the same positive results using this method. However, I did not have the problem with the orginal upgrade to Windows 10. Yet, I now have it since the November Windows 10 upgrade. And the Control Panel route mentioned above does not show. Anyone else having troubles?

#6

Yes, that will work but it suggests that you have something wrong in your router/gateway’s DHCP. If it is functioning properly then discovery is automatic.

#7

You may need to reboot as well.

1 Like
#8

Unfortunately all of the above is very limited. After a reset of the MyCloud unit, you do indeed see the shares. Following a system log out or reboot, you do not see them any more. However:

  1. Suppose that the unit is called WDMYCLOUD (default) and has (reserved) IP address 192.168.1.254.
  2. If you open up the Network display and type in either \wdmycloud or \192.168.1.254, you get the shares immediately. The unit also appears int the left hand Windows tree display under Network.
  3. Third party tools such as Total Commander or Free Commander are not updated.
    There is some poor interaction between the MyCloud firmware and Win 10 that did not exist under Win 7.
    WD Support would do well to take a careful look at this issue and perhaps provide a firmware update.

.N.B. There should be double back-slashes before wdmycloud and 192.168.1.254 in line 1 of list item 2…

#9

For unknown reasons, (my experience only) Windows 10 will take several hours/days to settle on which network devices are recognized and displayed. After a major change to my network, the WDMyCloud shares disappeared for several hours/reboots BUT reappaeared next day and have been rock solid ever since. Why? Only Bill and God seem to know and they are not sharing. :grinning:

Paul