Windows 10 error 0x8007003B

Hi all,

I’ve gone through win 10 sticky posts and tried all the solutions to try to fix my problem.

I get the following error when transferring large files (typically 700 MB>). The windows explorer tries to load my network when this happens. It’s almost like my connection to the network was distrupted.

I want to think this is my Windows 10 problem. But my Nvidia Shield TV tends to drop connection while streaming via Kodi. So I think the problem may be the cloud itself or my router.

Does anyone have good suggestions on how I should try to fix this problem?

What is your network setup?

  1. 100 or 1000 mbs,
  2. WDMyCloud connected to a router or switch
  3. All current updates done to Windows 10


  1. 1gb connection. wired.
  2. WD My Cloud connected to a modem/router. Motorola MG7310
  3. latest windows update: KB3176938`

Pull the WDMyCloud off the Motorola and add a Gigabit switch or a Gigabit router between the Motorola and the WDMyCloud.

As a matter of safety (avoiding unnecessary complications) when using an ISP supplied router, don’t connect directly to them. Use a switch.

This solved several problems for me.


I actually bought this modem and returned ISP supplied router. I didn’t find this complication before when I was using ISP supplied modem though…

Same problema here anyone found a solution?