Windows 10 Cannot access My Book Live with File Browser


#1

Hi,

I upgraded from Windows 7 (64-bit) to Windows 10 yesterday.

All went well except that I can now no longer access files on my LAN networked WD My Book Live in the normal manner, using File Explorer.

When I open the network location with File Browser the MyBookLive icon is there as a Storage , but it is not listed in the directory tree at the side. If I click on the icon it just opens up the MyBookLive UI log-on screen. The only way I can access the folders/files from there is to right click on the icon and select Open. Then the IP address of the drive appears listed in the directory tree, but only as long as it is open. After closing, it disappears again.

I can access the drive by IP using FTP (Filezilla) without any problem. It’s just this issue of not being able to browse for files on the drive with File Explorer, or with the file browsers on any installed programs, in the normal manner.

Browsing the forum, I see I am not alone in experiencing similar issues with Windows 10 and MyBookLive access.

The Win10 build that was installed is 10586.17.

Would appreciate advice.

Thanks.


#2

BTW - I’ve tried rebooting the MyBookLive drive, but no change. And I’ve attached a screen grab of what appears when I browse to Network with File Explorer:


#3

Can you use File Explorer to access network shares using the MyBookLive’s IP address instead of it’s network name? I’ve tried to induce same or similar issue on a MBL-Duo I’ve got and it just keeps on working. the only real difference between the MBL and the MBL-Duo is the former is a single drive and the other has two drive.

Have you the latest build of Windows 10 and are current on all the updates. Also, just make sure that the Workstation service is enabled, started and configured to start automatically with Windows.

Have you got any third party firewall programs? It could be that. There have been a few who have had similar problems and it’s been a 3rd party firewall.

So, at the moment it’s troubleshooting. The problem might not be the WD NAS. I’ve had no problems accessing any of the NASs with the original build and the current builds of Windows 10.


#4

Thanks, I’ll try my best to those answer those questions that I can, but I’m really not familiar with some of the things you ask. When I installed Win7 there were no such issues to deal with.

Again, I’m not really sure how to do that. Like I said if I just click on the MyBookLive icon under Storage, it just opens up the UI logon page. But if I right click and select Open, I can access all of the drive folders. If I select Mount Public Share instead (which I’ve just tried), well yes, it then creates a mapped drive for the public shared folder. Is that what you are asking?

As per my first post, the build is 10586.17 and yes I ran updates.

How/where do I check that?

No third party firewall programs. Just windows firewall and the router firewall.

Cheers.


#5

Windows 10 is not on build 1511. That comes through Windows update. Windows 10 home or Windows 10 pro? If Pro, have you deferred certain updates? Installing the latest build of Windows 10 may fix this issue.

To access by IP in File Explorer’s address bar start the file path with \ and then right after the two backslashes type the IP address. So, if the IP address of your NAS would be 192.168.1.40, you would see . . .

Press enter on the keyboard and see what happens. Use the IP address you assigned to your (Network Addressed Storage) NAS or the router assigned to your NAS.

Log in to the MBL’s dashboard to discover it’s IP address. You’ll find the information on the page shown ., . .

(I’ve reserved an IP address on my router. I’m too lazy to use static IP addresses for my NASs.)

Try access the NAS the I’ve explained. It’s possible the network NetBIOS name browsing is not working, but your MyBookLive (MBL) as actually there.

So, before proceeding, can you access the NAS’s files that way. Not by referencing the MBL by name. Referencing it by its IP address.


#6

Thanks for your advice.

Actually, after posting I ran into some problems, unrelated to MyBookLive, that forced me to recover a disc backup I had made after the Win10 with Acronis True Image. Unfortunately, that lead to its own set of problems which forced me to consider either re-setting Win10 or roll-back to Win7; I chose the latter, for now.

If, as you suggest, this issue with MyBookLive might only be resolved with a clean install of the latest Win10 build, and not the upgrade version, that’s something I need to carefully consider. As far as I can see the only possibility of going back to Win7 then, if things don’t work out, would be recovering a pre-upgrade backup and then I am unsure if this would present problems for registration.

If I do have another go at the upgrade I will try your suggestions.

Thanks again.


#7

Thing is, I upgraded from Win 7 to Win10 and everything just kept on working, but everyones’ computers are configured unique. As you are considering a clean install, make sure you create an installation DVD for the version of Windows you are using and use Balarc Advisor to get all your software licence keys.

Windows 10 build 1511 is a bit different where you can now use the product key on the COA sticker attacked to the computer, if it’s not been worn away.

The issues you’re having are, honestly a puzzle. It’s because I should also be having major headaches with my MyBook Live Duo, and I’m not. It’s just behaving.


#8

I have found a solution to this problem, which I also encountered after upgrading to Windows 10 on my Samsung laptop.
After much reading online, I called up WD tech support, and got the problem resolved by the tech. assistant in 5 minutes!
Turns out in my case Windows 10 was not automatically updating the network locations on my LAN at home, which is how I have the WD My Book Duo set up.
She instructed me to download (from the WD downloads section of the WD webpage) a program called “WD Discovery”.
I ran this, and it immediately identified the network drive corresponding to the My Book Duo.
I then went to My Computer folder and was immediately able to access the WD My Book drive before.
Hope this helps others in the same situation, I must say It is the first time in my life that calling tech support phone number led to an immediate and successful resolution of my problem, so kudos to the WD tech team, at least the one servicing the middle east which is where I live!


#9

Did this also resolve the issue of you drive not showing up under the Network tree? I am having the same issue as you after a recent Windows update.
Any chance you could point us to a link for this program? I’ve come up short with Google…


#10

Hi Brian,Yes, the drive now is shown under the network tree. The last step of the wd discovery software’s scan for drivers allows you to assign a “letter” to each drive, and that name is the one that shows up on the network tree.The link to the WD Discovery download page is the following:


Good luck.


#11

Thanks for the further feedback on this. I haven’t reinstalled Win10 as yet, but if/when I do I’ll see if this WD Discovery tool resolves the issue. Cheers.


#12

Well, that’s a big negative on the fix, Ghost Rider… My MyBook briefly showed up with the IP address instead of the Netbios name under the “network” tree the 1st time I ran the app, but as soon as I closed it down and refreshed, it’s gone, and hasn’t come back.

The tool for drive mapping is really pointless, as you can do this with a simple right-click > map drive anyway…


#13

I wonder if the behaviour of this on Windows 10 build 1511 has changed. If I right-click (opposite button if you swapped button) and then select Open from any NAS icons in the Storage category then all the network shares appear as they should, but the NASs are referenced by IP address and not name. Would be nice if they did appear under the Computers category.


#14

WD Discovery didn’t work for me. :frowning:


#15

Just checking in to see if a sure fix for this has come about. I’m still holding back on (re)upgrading to Win10 until there is one. This is a “deal breaker” for me.

Surely if this Discovery Tool does not resolve the issue, WD need to come up with a proper solution. Do they even read these pages ?


#16

Thing is, the MyBook Live Duo is more or less the same operating system as the MyBook Live. All I can tell you and everyone else is that I upgraded to Windows 10 and it just all worked and is still working.


#17

Have you been able to fix this? I am having the same problem. I’m doing an update on windows now hoping that this will help.


#18

Need some information. From what operating system did you upgrade to windows 10? I upgraded from Windows 7 Ultimate to Windows 10 Pro,.

If you can, run the following command on a command prompt started with administration privileges:
%windir%\system32\secpol.msc /s

If it works, is the setting shown the same on your computer?


#19

I upgraded from windows 8.2 to 10. I tried that in the command prompt and it is not recognized as an internal or external command, operable program or batch file.

At first it worked fine but just as of lately it stopped working.


#20

I’m having a hard time finding the policy editor in win 10.