Can't map MyBookLive share on Windows 10 anymore

On Windows 10 PC last time I accessed file share on WD MyBookLive on May 2, 2022.
Since May 25, 2022 I was not able to map this share anymore (either in File Explorer or “Net Use”).

Meanwhile I am still able:

  1. to access Dashboard at http://192.168.0.143/UI/#, view and add users, view and add shares etc.
  2. to view files on this share in File Explorer under:
    This PC >> MyBookLive >> storage >> [Share name]

You might try the My Book Live setup software. If you already have WD QuickView installed, it can be used to map your drive. Right-click the icon in the System Tray:
wd1

Select Map:
wd2

If that doesn’t work (or the software is not installed), you can download the setup and QuickView software from here:

https://support-en.wd.com/app/products/product-detail/p/231#WD_downloads

1 Like

It’s exactly the same behaviour in File Explorer and WD QuickView.
I see a dialog box requesting User ID/Password.
The same dialog box is displayed one more time after I entered valid credentials and so on …
image

One more symptom is a prompt to enter a User Name when using “Net Use” command:
image
Previously this command was completing successfully without any prompt.

In the image of the Map Network Drive dialog in your second post, I see the bottom checkbox checked:
drive

That checkbox says “Connect using different credentials”. I assume you’ve been trying everything, but just in case, have you tried with that box unchecked?

mb0w81651, it’s the same:
image

Anyway, I do not expect this dialog box at all.

Anything in these threads help?

mb0w81651, I tried a lot of proposed solutions.
I would like to switch from “trial and errors” method to diagnostic based method.
How can I get more information on what exactly caused this error?

Later note: I tried one more procedure - it did not work.
I will try factory reset noformat later.

Let us know how that goes. I’m not an expert by any means, just making suggestions that I would try if it ever happened to me (and since it seems to come out of the blue, it just might someday). It could be that there isn’t any one thing that causes the problem and trial-and-error is all that can be done.

mb0w81651, I have not found anything of value in Events Viewer.
I am thinking about using Wireshark but do not have it installed on this laptop.

Try this:

Turn on SMB 1.0/CIFS Client

After a few weeks this issue has been resolved without my involvement.
I assume that drive mapping has been broken by one of Windows updates and that subsequent Windows update has fixed it.

As a result I spent a lot of efforts unsuccessfully trying to fix it while I should have just waited a bit. :frowning: