Cannot Map My Book Live in Windows 10 - Repeatedly asks for login credentials

I looked through the threads and couldn’t find an answer for Windows 10 so I hope I am not repeating a thread.

I am having serious issues with getting My Book Live to map in Windows 10. I recently had to reinstall Windows due to an errant update and now I cannot get my MBL drive mapped. It was there before. It keeps asking for credentials. I reset the drive back to Factory Defaults. I tried the “net use * /delete” and received a message - “There are no entries in the list.”

Any assistance would be appreciated.

PKGary

Hello pkgary ,

While entering the credentials make sure you are entering them correctly. In the dashboard of the drive, please check under the USER tab, you will get the choices of the users. Select the admin and see the username and the password. These credentials of user you have to put while logging in.

Thanks!

Hi Peter,

Thanks for the suggestions and assistance.

I have tried several times and made absolutely sure the User Name and Password are correct (case sensitive and all). I have reset to factory settings. It just continues to ask for credentials and loops over and over. I must admit, it is frustrating that there is no direct method of getting to the drive.

Any suggestions are appreciated.

Thanks,

Perry

Hi. Were you able to solve your issue? I’m facing exactly the same problem. Very annoying. Thanks for any hints.

This sounds like my story. Windows 10 Spring Creators Update has disrupted everything again, but at least I’m not rebuilding my laptop this time like I had to after the Fall Creators Update.

I’m unable to map MyBookLive also. Is there a link that includes a solution?

Finally found an answer that works. Go to:

Scroll down to:

Mapping a Network Drive through the Drive Name or IP Address

If you don’t have the search magnifying glass in your task bar, right click on the Windows Start icon in the bottom left corner and select Search.

Previously I had to use the IP address to map my old MyBookLive drive, so I used it this time. Now when I click on the IP address under Network, the folders are accessible in Explorer. I mapped each or the shares also so I can go directly to them.

I received some instructions from WD Support but I didn’t understand them, it was way too technical.

What I did was to reset the HD (using a metal clip). After that everything was back to normal. It was so easy.

I trust that the reset left all your files intact?
I am in a similar situation: My MBL cannot be seen any longer by my laptop via wifi. It can be seen by a desktop wired to the router, as well as my TV, which sees the MBL via wifi. Don’t know what’s going on here!

Hi

Yes, all files were intact.

I am thinking a new external hard drive, copy the files, and get rid of my old MBL.

We had 2 power shut-downs in our building recently which MBLs usually don’t like. My last one “died” after several incidents of electricity interruptions but I was still able to recover the files.

Good luck.

Thanks for all the tips here but what worked for me was getting the mapping order correct.

In the mapping instructions linked above it clearly states “Please map private folders before public”

So I removed the mapping to the Public folder, mapped the private folder using the admin credentials (user folder credentials did not work), then added the Public folder back in.

Job done! :smiley:

I have struggled with this for a whole day on a new Win10 Home laptop, messing up with SMB1 support, gpedit.msc, registry and a whole bunch of “tips”, until I found a page right here at WD Support which pinpoints the problem: Share Access Failure - Multiple Connections To a Server or Shared Resource by the Same User Not Allowed .

The default Win10 login uses an online MS account. Changing the Windows login to a local account just made it. After that, I could map both a private and the Public share to drive letters.

I hope this still helps someone.

Fabricio Rocha
Brasilia, Brasil