Unable to access files in My Book Live


Appreciate somebody can advise me how to access my files inside My Book Live (MBL). You see, out of the sudden, the icon of MBL cannot be found from the window explorer of both my laptops with one using Win 7 and another Win 8. I did not upgrade them to Win 10.

The LED light infront of MBL is green and it is non-blinking and I have not done any software update to it.

I have not done a reset on the MBL fearing the process will erase all files inside it. Please help. Thank you.

Try this software:

The download link is:

Thanks Myron.

The software runs well but unable to detect MyBookLive. Do I need to reinstall MyBookLive and how to reinstall it? Thank you.

Do you know what IP address your MyBook live is on?

  • Have you manually assigned an IP address to it. (Static IP)
  • Have you let your router assign an IP address it? (DHCP assigned IP address)

If DHCP then have a look at your router’s settings, specifically the list of IP addresses the router has assigned to stuff on your network and see if your MyBook Live’s IP address is in the list.

On the network port of your MyBook Live, where the RJ-45 connector goes on, what are the two LED’s showing? Are they on? Is only one LED pseudo-randomly flashing and the other constantly on?

Thanks again Myron.

The RJ-45 connector has only 1 green LED light on, without blinking.

When MyBookLive was working, there was a IP address indicated with it on its icon. I did not assign to it so it should be done automatically.

I cannot see the IP address on the router list. What can I do to rectify the present situation?

Now there is an interesting thing. One LED shows that there is a Link with the router. It’ll be either Green and sometimes Yellow depending on the link speed. I think on the MBL it’s always green.

The second LED usually shows activity on the line. Even if there is nothing happening there should be at least the occasional flash.

Let’s try approach this with what can be done and suspect everything. Can you change the network cable and also use a another network port on the Router. Have a look in the RJ-45 socket on the MBL. Do any of the 8 metal fingers appear abnormally bent?

Can you try the MBL’s network cable with another networked device to verify that the cable is actually working?

If that don’t work then the reset button can be tried., but the reset button only does three things on the MBL. It resets the root password that’s used for SSH access to the MBL’s operating system, it resets the owner password to blank and resets the networking set-up to use DHCP. The reset button will not erase your files.

This is what the reset button triggers:

# © 2010 Western Digital Technologies, Inc. All rights reserved.
# resetButtonAction.sh
# This is called by resetbtnd whenever the reset button has met the criteria for a reset.  This script implements the actions for the reset button.

logger "reset button pressed, invoking reset actions"

# remove owner password
modUserPassword.sh ${owner}

# set root password back to default
echo "root:welc0me" | chpasswd

# set network to dhcp


The WD Discovery software should be able to find the MBL. I have the two drive version and it’s generally the same as you’ve got apart from two drives and RAID1 or spanning can be configured. WD Discovery finds my MBLD.

The MBL should have it’s MAC address shown on a label. Try reserve an IP address on your router for the MBL’s MAC address. That’s what I do at home. All my stuff is configured to use DHCP and I manage what gets what IP address from the Router. It’s a whole heap easier if I have a gadget that does not need an exotic network configuration.

Thanks Myron.

I have connected the MBL directly to my laptop (by passing the wireless router) using the RJ-45 cable. I can access to the media files only via Twonkey. Please advise how to access the microsoft files.

I can re-assign the IP address for the MBL. I read some of the earlier replies in the community (and yours were in it) and i remember someone saying use the same IP address as the wireless router. Is this advisable? If not, how do i assign a IP address for the MBL? Thank you.

With the MBL directly connected to your computer, ping the MBL’s name and see what IP address is given. It’ll be a private range address that is allocated internally by the MBL when it can’t get an address from a DHCP server.

Try access the files by typing \\ followied by the MBL’s private rage IP address in Windows Explorers address bar. I don’t think the MBL will appear in the Network folder.

Did you change its name?

Thank you Myron. You are very helpful, responsive and knowledgeable in this WD device. I sincerely hope WD would recognize you and your superb assistance on their behalf, making their work so much easier.

My problem is finally solved with a simple reset of the device and everything appeared as before. However, the IP address is different now, auto-generated by DHCP, I reckon.

I hope this tread helps those who are facing the same problem as me that when you click onto the MBL icon and it simply did not respond or open out of the blue where:
you did not change any configuration of the device setting;
nothing wrong with the connecting cable;
nothing wrong with the wireless router;
Then I suggest you press the reset button at the back. Rest assured that it will not wipe out the data inside the device.

Merry Xmas to Myron and to the community here.

1 Like

You and Family also have a good Christmas and the the best for the new year too.

If you’re not planning to take your MBL to other network at other houses then maybe it may be a good idea to set a static IP address on the router, Use an IP address outside of the pool of IP addresses your router allocates from or on the router reserve the IP address your MBL has been allocated so whenever your MBL requests an IP address from the router, it’ll always get the same one. The latter is what I’ve done and it works well.

I recognise how for some it can being concern that use of the reset button will wipe out data. It does not. it just resets the SSH root password, resets the networking configuration to the out-of-the-box settings and reboots the NAS.

Out of curiosity, when you wish to turn off the MBL, do you just turn off the power or do you go to the Dashboard UI or use WD QuickView to shut-down the MBL before unplugging it? It should survive quite a few sudden power-cuts but a controlled shut-down is desired. I think the software engineers trying to take into account that many people may just pull the power plug instead.

Always good to do all the basic checks first. Those checks are the ones that seem to be omitted. I’ve learned to assume nothing.

For example, a friend has a problem with a cordless phone. When I did my checks I noticed that the RJ-11 plug in the phone has two of the sprung metal fingers bent so no connection on two wires, and thus the phone didn’t work. That’s why I suggested to check the wire and the RJ-45 sockets. Just in case,.

Anyway, glad it’s working. Make sure you keep a back-up of everything you don’t wish to lose. The data is the owner’s responsibility.

Thanks for following up Myron.

My MBL is used as my back-up and therefore it is strange to get a back-up to back-up the back-up. But after this incident, I will get a mobile hard-disk, just to be safe.

When I turn off the device, I just pulled the plug as there wasn’t any movement inside the device. My MBL is always on and stays home. So without any plugging and unplugging of the cable, I did not suspect the connector was the problem and it wasn’t.

It is still strange to me that without altering any configuration and it was working fine the prior day would give me the problem as described.

Nonetheless, thank you Myron and have a wonderful year end holiday.

Get into the habit to shut-down he MBL before pulling the plug.

From the Dashboard UI:

When using QuickView:

You can help if there any power-cuts, but please tell the NAS to shut-down all it’s internal operations before you pull the plug.