A BIG Problem

Purchased a MyBook Live (1TB) and during a month worked fine, but suddenly I can't access to it and it's contents.
It began with front geen light always blinking, but now sometimes is stable but I can't connect.

(Mac OS X 10.7.2 Lion)

What I have done so far:

- Check cables
- Some power off.
- Some resets to put in factory default.
- Tried to access via WD Quick View, but no chance: it can find it.
- Tried to access via Instalation CD. No chance.
- Tried access in browser with "http://mybooklive.local/UI/. Nothing.

- In my router (Linksys WRT54GL), MBL is sometimes listed with 2(?) IP Addresses: (from DHCP I presume), and a strange IP Both IPs have same MAC Address. This 2 IP Addresses can coexist but last one appear and disappear…
- Tried access in browser with this 2 IPs. Nothing…
- Connected MBL to my computer. Reboot MBL and Mac. MBL is visible, but when I want to access it disapear. In Disk Utility is always invisible. 

- Contacted WD Support: receive the advice to link MBL to a Windows machine

- Connected MBL to a Win 7 machine: MBL not recognized. Receive the information: "Local Area Connection" doesn't have a valid IP configuration.

- Tried again with Mac and router after 8 hours of power off: Dashboard appear and when I was trying to do the full factory reset it goes off again... last information received tells that connection was instable...

Two IPs keep showing in router with the same MAC Address.
Green light is always flashing...
Is there any other way to do a full factory reset? A mechanic way, perhaps...?
Anyone knows how to fix a invalid IP configuration?
The problem is that MBL is full of personal information and of course I don't want to give it for replace with that files on it...
This is a very annoying situation. I have also a WD MyBook (500MB) and it works fine. Thought that MBL was also reliable.



pushing and holding the small recessed button with a paper clip for 5 seconds will reset your network info an the admin password, without affecting your data. 

go into your router and reserve and IP, out of the dhcp range, for your MBL.  On mine, I go into the router and it shows all connected devices.  Select the MAC of your MBL and reserve as specific IP for that device.  if you have other DHCP devices on your router just make sure you don’t create a conflict, or you may need to restart your other devices.

Thanks for your answer.

Tried again reset with no results.

Tried also a static IP (following your advice), outside the range of DHCP, but the second IP ( is always showing…

 Tried again in a direct connection with a Windows 7 machine and after diagnosis receive the message that “Local Area Connection doesn’t have a valid IP configuration”…

So, I can’t access to dashboard to do a full factory reset and give MBL for replace.

WD Support says that I’ve done everything so far… 

Maybe it’s a dead end.

In this case I’m thinking to open the case and try to  recover the HD…

Anyone knows what is  it’s internal connection? SATA?

sorry, I meant “select a dhcp from within the range your router has side aside”.  still, it probably won’t solve your IP configuration error.

do you have another computer to try a direct connection?  Have a friend bring over a laptop or something, maybe it’s your machine.