MBL My book Live Does not show up on the Network

Good day,

I have a My Book Live. it used to work fine.
it turns on.
Green light on in the back were Ethernet is connected.
None of the WD software are able to see it.
I tried link, smart ware pro,
My net view says there is a disconnected MBL at but when I try to connect to it via browser it does not work.
Besides turning it off and on and using a pin to press and hold the reset for 10 seconds, is there anything anyone else can suggest?


I assume you can get at your router and other things connected to your router. Does your router’s admin function display devices attached to the router? If so, does your MBL show up? (I’m going to assume the answer is “No”.)

You might try a different Ethernet cable. If the gods are with you, your problem will have a simple solution like that.

I tried swapping cables: no change.
I tried looking at the router to see what was connected and it was not there.
I also tried running WD my net view, and a lot of stuff shows up, just not the MBL

Any ideas?


I’m having the exact same problem. My drive was working fine, attached to my router, just a few days ago. Now it no longer shows up on my network. The led lights on the ethernet port look ok, one is steady on and the other blinks away as you’d expect. I cannot tell if there are other problems because my front led stopped working years ago.

Like the other user, here’s what I tried so far:

  • tried rebooting router
  • tried assigning the mbl with a fixed ip address (based on mac address)
  • tried changing the cable
  • tried power off/on
  • tried reset holding the reset button 4 seconds
  • tried reset holding the reset button 30 seconds
  • tried connecting the drive directly to my laptop via ethernet cable, nothing happened.

It looks like the drive is simply not showing up on the network and it is not getting an IP address. What else can we do?

Thank you.

Hello Everyone,

Is there anyone with any knowledge that could help us beyond what we tried?
Or anyone know of a way to remove data from the drive itself?

Thanks for any help.

I’m also having problems connecting to the MBL (still unresolved), but the MyCloud app still works. Have you tried that?

Has anyone provided you a solution?
I am having a similar issue. We have been using WD My Book live for 3 years now with various laptops and desktops connected…no issues. I acquired a new laptop (Lenovo thinkpad with Windows7) that refuses to connect to the MBL. The MBL will not show up in my Network connections no matter what I do. I have updated the firmware (several times), installed all the drivers from WD for windows and still have not had any success.

The annoying thing is, this laptop ‘sees’ the MBL drive in certain ways…I can go to the online MBL Live dashboard. It shows me all the information about my MBL (I.e drive name, amount of memory used, serial number, firmware version). All that information is there but I still can’t get access to my files.

Anyone have any suggestions?

I had a main board go put on my MBL My Book Live 1TB drive caused it to not be seen, but the lights were still lit. I tried that HD in a plain HD enclosure and my computer only offered to format it (I couldn’t do it), I tried it in a “My Book essentials” enclosure and again format was the only option given, but I waited…

I bought the same model MBL 1TB on ebay (orange box and everything to ensure the same mail board) and as soon as it was delivered I popped the case open and swapped the HDs and when I plugged it in… My old drive was back… files, settings, ip address, file permissions… everything.

The WD Smartware software showed a “Smart Status failure” but I put the drive that came in it in the plain HD enclosure, formatted it, copied the files from the My Book Live HD to the plain HD,

I hope this helps.

I have the same problem… green light flashes but my book live duo never shows up in router or on network??? I have a lot of data I need off this harddrive. I am on windows 10 why isn’t there a firmware update that should have fixed this problem?