MBL won't connect to network

I have a Western Digital My Book Live NAS device (the same type that was recently hacked). Mine was offline in a storage box during the hack, but now I’m attempting to get it back online to retrieve my data.

I connected the NAS via ethernet cable to my Netgear Orbi router (same router it was connected to previously) and powered it up, but none of my 3 computers (Win 7 laptop, Win 10 laptop, Mac PC) will recognize the NAS over the network. WD’s own NAS discovery software won’t find the drive either.

I tried the 4-second soft reset with a paperclip, but that resulted in no change.

I tried connecting the drive directly to my computer via these instructions, using multiple types of cables (one normal, one crossover), but the drive was not found.

The front panel status light on the drive is Solid Blue, with an occasional quick flash of Yellow (every 7-14 seconds). Per manual, Blue means “Power On” (but not ready).

The rear ethernet lights perform the same pattern over an over: bottom green light is solid, then upper green light flashes 3 times while lower is solid, then both lights turn off, then the pattern repeats.

Any help to get this drive back online would be appreciated! I don’t believe it was a victim of the hack since the drive was disconnected and in a storage box, and it hasn’t yet successfully connected to a network since then.

You should try contacting WD’s Technical Support about this for live assistance and troubleshooting:

To Contact WD for Technical Support

support.wdc.com

LOL, ok. The product and its support are both long discontinued.

When you have it connected to your router, does your router see it? If you logon to your router, does the MBL show up in the client list? Has the router assigned it an IP address? If your router doesn’t see it and you’ve tried different cables, maybe the ethernet port on the back of the MBL is dirty. You might try cleaning the contacts.

Great question, and thanks so much for the reply.
It does not show up in the router client list, and I’m not aware of any IP being assigned to it. The odd thing is, the MBL ethernet port lights flash (as described in my post) when I connected the router to MBL, so I had to assume that some contact was being made.

I’m not home right now, but later I’ll check what the lights on my MBL do when the ethernet cable is connected and disconnected (both the rear ethernet light and the front led). (My MBL didn’t get hit with the attack for whatever reason. I have since used Parental Controls in the router to disconnect it from the internet plus turned off upnp, so I continue to use it. At my own risk, of course.)

1 Like

When the ethernet cable is disconnected from the router, there are no lights on the ethernet connector (OF COURSE THERE AREN’T, what was I thinking?). The front LED is solid yellow.

When the ethernet cable is attached, the bottom ethernet light is solid green, the top ethernet light flashes green randomly every few seconds. Unlike yours, the bottom light never turns off.

The front LED is solid green when not idle. When idle, it WOULD be solid blue except the blue LED on my MBL stopped working years ago. So, on my MBL, the LED is solid OFF when idle. Unlike yours, it never flashes yellow.

So, in retrospect, I don’t think this helped you at all. The mere fact that your router doesn’t see the MBL would seem to indicate a problem with the connection. That’s as far as my limited knowledge takes me. Hopefully, it’s just some dirt in the MBL ethernet port. Try blowing into it, insert and remove the ethernet cable several times, swab with qtip and alcohol…