Royally screwed up the My Book Live

Hi all

I need some help to sort out a problem which is entirely caused by me! I have a 2TB My Book Live (MBL from this point) and it was working fine. I was connecting to my router via WIFI and the MBL was connected to the router too. I could access it from my Samsung TV as well.

I then moved the router and MBL to another location. The MBL is on and has constant green light. I can see it in network screen on PC (Windows 10) and when i click to open it then it goes to the MBL using the IP of Status is fine. I can also see it when i click on “This PC”" in FIle Explorer.

My problem us that i can’t see it in my network tree on the left of the screen. Or rather i can see it but when i hit the right arrow to show the shares and be able to move stuff to it it then comes up with the error code"0X80070035 Network path not found"

Now I have moved it all back to the same location as before and i can’t see the MBL there anymore!!!

Any clues to what might have happened? I can assure you i have spent hours today on this community and also general searching and everything i tried doesn’t work

Just to add that i can see the drive from my phone and Samsung TV after moving it back to the original location

Would love it if someone can help


Simply changing the NAS from one place to another should not result in this issue. What happens if you try to unmap and remap your NAS? Are you using the same IP configuration as before? Are other computers showing the same error message with your unit?

1 Like

i got it working…but in the same way i don’t know how it stopped working i don’t know i fixed it!

Thanks anyway