My MBL is bricked?

Hello all.

Just last night everything was fine and I was watching media through my MBL!

This morning the Windows explorer doesn’t show the drive, cannot access through http://mybooklive (directs me to a book shop!), nothing happens doing the reset with the paper clip on the back, WD set up disk cannot find the MBL.

On the back the green light flashes occasionaly and the lower light is on a constant yellow.

My MBL is connect through an ethernet cable to my router. I also tried connecting directly to the PC but still I cannot access or find the drive. As far as I can see there is no problem with the router as I have internet access. I also tried turning off my anti-virus. Nothing. I have the MBL for some years now and there are only two things I can think of: the front light  is off (but it is like that for a looong time like months, some problem with the LED I guess) and the firmware was not updated. But only last night it was working fine and I was watching a movie stored in it through my Apple TV! It seems my MBL vanished from my home network.

Can anyone give me an idea how can I regain access to the MBL? Is it bricked?

Thank you for any suggestions.


I woke up this morning to a similar scenario with my My Book Live (2tb) nas.  I can’t navigate to the admin page and the network shares have seemingly vanished.  I did try a hard reboot and eventually the front led went to a blinking ‘green’ but isn’t on solid.  I’m wondering if there was some software update last night that may have preceeded this?

In any case, I will be working on recoving that drive this evening and hopeful that someone posts a possible fix.



well, it seems we’re on the same boat. What do you mean by “hard reboot”?


I had the same problem on one of the two MyBookLive that I have in my home network connected directly to the same routers - the night before, it was everything OK, until almost midnight i noticed I lost connectivity to that faithful MBL box, when I came closer I notice there is red light on front LED and I did unplug the power cable and let it rest the whole night but then the next morning I plug the power cable back, the LED turns green and then blue occassionally - but I could not connect to its web admin console and this MBL vanish from my network…

I had the posted into this same location but different topic thread.

I wonder what happen…

If you find a solution, please tell me! I also sent an e-mail to WD e-mail support. Let’s see what they say. I’ll only try the “unbrick” method posted in the forum as a last resort.

Reply from WD e-mail support:


As last possible step you can try is connect My Book Live directly to PC’s LAN-port and reset the unit. If the PC won’t recognize the drive, then it can be confirmed as failed and in need of replacement."

Will try tonight but I’m pretty sure it won’t work.