Win 10 PC cannot access MyCloud PR4100

Win 10 PC cannot access MyCloud PR4100 NAS connected via LAN to router. “Windows cannot access…”

Other computers, when on, can connect to the NAS and I can access files normally.

The NAS is visible to the router and is assigned an IP address. If I enter the assigned address in a browser window, I am able to sign in to the interface.

Network Discovery is turned on for both Private and Public networks. “Turn on automatic setup of network connected devices” is checked. “Turn on file and printer sharing” is selected. “NetBIOS over TCP/IP” is selected. I’ve tried turning off firewalls. I’ve performed both a 4-second and 40-second reset.

Help, please!

You should move this to the PR4100 sub-forum.

Latest My Cloud OS 5 Personal & Network Attached Storage/My Cloud Pro Series topics - WD Community

As a troubleshooting step try enabling SMB1.0 in Windows and see if that fixes the issue. Generally SMB1.0 is disabled by Microsoft due to security vulnerabilities.

Enable SMB 1.0 CIFS File Sharing Support for My Cloud, My Cloud Home, My Passport Wireless and Legacy NAS Products

If running third party firewall software on that specific computer, check that software to ensure it isn’t configured to block access to local network clients.

Done and done. No better

I am going with “credential manager problem”

4 and 40 second resets imply new usernames and passwords.
Windows Credential manager does not like having a network device with more than one set of logon stuff.

Try going into credential manager and deleting all references to the Device name and the IP address of the NAS.

Well, that got us part way there. I can access the “Public” share now, but others return:
"An error occurred while reconnecting X: to \MyCloud PR4100\Xxx
Microsoft windows network: The local device name is already in use.

The connection has not been restored."

Here’s what works:

  1. Set a share profile “On” in “Public”
  2. Access it from File Explorer.
  3. Set that share back to “Off” in “Public” and set appropriate user accesses.
  4. Repeat for each share.

Why? I dunno… Does anybody out there have an explanation?

Oh, well. Only works until reboot of the PC. Only “solution” for now is to set all shares to “Public.”


Bennor gave you the best thing to check, SMB 1.

Your topic is in the sub-forum for owners of the single bay WDMYCLOUD.

SMB 1 was enabled for Client, but not server. Once I enabled it for both, I was able to access most of the shares. However, attempting to map new shares, I get error:

SMB 1 was enabled for Client, but not server. I enabled it for both, andam now was able to access most of the shares. However, attempting to map new shares, I get error:

That is a windows credentials manager issue.

Windows cannot comprehend that there may be multiple users on a single network device. For any given PC (more specifically each user account on a PC) can ONLY log onto a network device (a single device name or IP address) with a single username/password combination.

So if the NAS has two shares, Share1 (only user is Jack) and Share2 (only user is Jill). . . . . Once Jack logs into his share1. . . .Jill will not be able to log into her Share 2. Windows will reject the login credentials. Unless you first manually wipe the credentials within credential manager (painful).

Jill will have to use a DIFFERENT PC to access share 2. Once she accesses her share on the second PC; Jack will not be able to use that PC to access his share.

If you have two shares on the NAS, but they have the SAME credentials (Same user name/same password); you will be able to access both shares.

The shares are being accessed by different people on different PCs, and can be mapped, and accessed, at will from two out of three PCs. The credentials are not stored on the problem PC (#3.) #3 can only access “Public” and one other share, and refuses to access or map any others. admin supposedly has access to all the shares, but cannot from #3.

If you have ever logged onto the NAS from PC#3, it has stored the credentials you have logged in with.

Have you verified by opening Credential manager and verifying there are no entries for either the NAS IP address or it’s name? Type “Credential manager” into windows search, and look for entries under the “Windows Credentials” area.

When you say “admin has access to all shares” – - does that mean the admin (using admin login and password) is using that PC exclusively?

Credential manager on #3 has no entries for the NAS, either by name or IP. I am required to input name an password every time, and I do not click “Save my…”

Admin uses all 3 pc’s, successfully on #1 and #2. Have tried giving other users access to various shares, but they cannot access from #3 either.

The really odd thing is that there is ONE share (called “Backups”) that #3 CAN access. It’s settings on the NAS are the same as others that can NOT be accessed.

When I first enabled SMB1 on #3 all seemed to work well. Came back to it a while later, and all but “Backups” and “Public” are inaccessible.

It’s a puzzle…

Now I am out of ideas.

BTW: When you say “Don’t save password”. . .it does force you to log in everytime. It should, however, still make an entry in credential manager. Hmmm. . .in fact. . .I am a bit puzzled that PC#3 has no entry for the NAS. . . .

Yes, if I don’t check “Save my credentials” it will ask me for them the next time I try. However, I am still getting the “already in use” error. I don’t know where else Uncle Bill (Windows) saves drive letter assignments. PC#3 has no entry for the NAS in credentials manager because I deleted them (there were 2,) trying to force a new logon. If I had any more hair I’d be pulling it out.

“Backups” and “Public” are accessible because they are set to “Public” on the NAS share profile.

The screen capture is showing you appear to still be having some sort of Windows Credentials issue.

As a troubleshooting step, if you haven’t done it already, remove all mapped Shares on the Windows PC for each Windows account login on that PC. For each Windows account login, check the Windows Credentials Manager > Windows Credentials and remove any My Cloud entries. Then reboot the computer and try again.

And double check in the My Cloud Dashboard that each Share you are trying to access has the proper permissions set for each user that is trying to access the Share.

Reboot the router if you haven’t done that step already.