Can't access PR4100 on new PC or old PCs

Hi. Can see my PR4100 but cannot access it from any of five PCs on home network. Three are running Windows 10 2004, one Windows 10 1909, and one Mac Catalina. I’ve also tried to reach it from an iPad and iPhone. No joy. I can see content in Plex on various devices but nothing plays.

My PR4100 has been working without incident for years. Now that I’ve tried to connect to it from a new PC, I cannot get to shares or to dashboard on the new PC or any of the other PCs on my home network that have been connected for several years. The NAS no longer shows as the name I gave it years ago, and instead is back to the default \MYCLOUDPR4100.

I can’t access the PR4100 through the IP address or the \SERVER\Share. I get a variety of errors–but the most common is "It is available but is not responding to connection attempts. A firewall or network security policy on the remote computer might be blocking the connection on port “file and print sharing resource.”

I have…
0. Enabled NetBIOS over TCP/IP and tested both on ethernet and Wi-Fi.

  1. Turned on SMB 1.0 in optional features. This allows Windows to “see” the NAS. If SMB 1.0 is off, Windows can’t see it…even though the NAS was already set to accept up to SMB 3.0 and on all the other Windows computers I did not have SMB 1.0 enabled.
  2. Done the 40-second reset. No effect.
  3. Opened ports 80, 443, and 445 as TCP and UDP in Windows Firewall. No effect.
  4. Added credentials in Credential Manager for the shares and for the IP address. No effect.
  5. Ensured all the appropriate services are set to automatic and are currently running. No effect.
  6. Made the PC discoverable using Network on Control Panel. No effect.
  7. Reset the network (multiple times) using Network in Settings, flushing DNS in Command Prompt, releasing and renewing in ipconfig. No effect.
  8. Ensured the network is set to private and that File Sharing and Network Discovery are on both Private and Public networks. I’ve done the trick to turn them off and save and then on and save. No effect.
  9. Created a DWORD(32-bit) key in Registry Editor to allow a connection. No effect.
  10. Rebooted NAS, power cycled router, restarted computer…multiple times. No effect.
  11. And a bunch of other stuff that I’ve found on a variety of help sites. No effect.

Nothing is working.

PR4100 has the latest firmware 2.31.204