Win 10 Can't Connect to MyCloud PR4100


#1

My Win 10 laptop is generally unable to connect to my MyCloud PR4100 NAS connected via WiFi to the router. I can sometimes see the NAS in File Explorer/Network (sometimes in the Computer section but not Other Devices section, sometimes in the Other Devices section but not in the Computer section, sometimes in both, but usually in neither), but regardless which combination I can’t read or write to it. Infrequently, I can connect by entering “\mycloudpr4100” in the File Explorer search bar. Usually, the Windows error says: “Network error. Windows cannot access \mycloudpr4100. Check the spelling of the name. Otherwise, there might be a problem with your network. To try to identify and resolve the network problems, click Diagnose.”

  • Another (hard wired to the router) computer is able to connect to the NAS most of the time and I can access files normally.
  • The NAS is visible to the router and is assigned an IP address. I can ping the NAS from the router. I get the same error if I enter the assigned address (192.168.0.103) in a browser window.
  • The laptop has current Windows 10 and Dell SupportAssist updates.
  • Win 10 System File Checker (SFC) found no file issues.
  • I’ve tried everything in Answer ID 14925: Network Discovery is turned on for both Private and Public networks. “Turn on automatic setup of network connected devices” is checked. “Turn on file and printer sharing” is selected. “NetBIOS over TCP/IP” is selected. I’ve tried turning off firewalls. MacAfee AV is the same product/version which is used on the hardwired computer that has (almost) no problems. The recommended services are all running and set to automatic. The NAS MMAC doesn’t appear on the Address Resolution Protocol (ARP) list. I’ve performed both a 4-second and 40-second reset.
  • I’ve enabled SMB 1.0/CIFS File Sharing Support per Answer ID 20736.

Help, please!


#2

@Waldroop See the correct sub-forum.

https://community.wd.com/c/network-attached-storage/wd-pro-series