Impossible to connect to PR2100 after win10 reinstall

Good morning all,
after reinstall win10 pro on my laptop I have a problem with my NAS, a WD PR2100.
Initially I had OS3, then I updated to OS5 but nothing changed.
I see it on the network but I cannot access it.
Initially, the error was 0x80070035.
After I have applied all the steps to resolve the problem suggested by WD and/or microsoft, the system ask me user and password but for every user it says the password is wrong.
On the NAS registry I see:
SAMBA CIFS: Authentication for user [xxxxx] has FAILED.

I also tried to create new user account on NAS and on PC but it didn’t solve the problem.
I tried to change password on NAS but nothing.
Two others pc on the lan haven’t access problem…

Help me!
Thank you.

Make sure that the Windows Feature SMB 1.0 is enabled.

Nothing change with smb1.0 enable.
I have already tried.
And others computers connect to the nas haven’t enable mb1.

I don’t know why before reinstall win 10 every day function correctly. I think if a pc have already mapped network drive there is no problem connections, but the first time it is difficult to connect for mapping drive. In my opinion a recently update of nas or windows caused this problem.

Can you other tips?
I need to connect, I use nas for my work.
Thank you.

I use a fixed local IP address for all my units

but I still use the old WD Access app that may now be depreciated on my latest version Windows 10 64 bit

WD NAS has fixed IP. I also tried with fixed IP on my pc but it doesn’t work.

I tried to install WD access and pc see NAS but if I tried to “Upload file” I obtain the following error (in english means “connection to MyCloudPR2100 lose”:



Have you other tips?

Thank you.


In Control Panel, Network and Sharing Center, Change Advanced Sharing setting, is Network Discovery turned on?


I tried every combination.




Find the IP address of the PR2100 listed in your router’s connected devices.

Then, using that address, start a browser session (new tab or new windows) and into the address field enter: where is the IP address you found in the router’s connected device list.

If the connection can be made using the IP address you should see the My Cloud PR2100 login screen.

http:// has no problem to connect to NAS login screen.

httpS:// not connect.

Is this the problem?

Thank you.


Interesting. My experience is just the opposite. If I try to use just http the connection fails but using https works. I am using Firefox by the way. (And, yes, there are things Mozilla does in Firefox that are forcing use of https which probably explains my experience.)

If you can see the login screen using the IP address in the browser that means there is something about the Windows settings that needs to be changed. What exactly is the mystery.

Perform a search of the internet using keywords “windows” “error” “80070035”. It should produce a list of pages that will offer suggestions. The few hits I have scanned have lots of things to try, but unfortunately, none of those articles tell you how to narrow it down. You are left to try them all (as in trial and error).

A better way would be to find more information about the specific error that would help identify what element in the chain is failing the connection. There could be more information in the Windows event log that might help but I would not know what to look for.

And finally I will mention the existence of a very powerful tool used for analyzing networks and for troubleshooting. It is called Wireshark. It should be possible for a person with a very deep understanding of network protocols to devise a Wireshark session to gather the necessary data during a failing access attempt.

Good luck.

been a while since I play with Wireshark - good tool

the link had some interesting ideas on what may help

ONE simple thing that tripped me up ,years ago, was having my computer name TOO LONG

I also tried the link you suggested me but not work. It remained a mistery.
I decided to try a new clean reinstallation of win10.
After reinstall I didn’t install any software or update and check to connect to nas and magic: connection ok. Incredibly it didn’t ask password to connect…
At the first reinstallation a week ago I only uninstalled very few preinstalled program. One of this was onedrive. I don’t know if it was the problem but onedrive another time on other pc created me a big problem during a software installation. That software don’t work with onedrive and I don’t know why it created that problem, but I have the feeling that the problem could be onedrive also this time.
This problem remained a mistery.
In every case fortunately I solved.
Thank you for your support.