[SOLVED] OS5 upgrade, no longer able to access PR2100 from Windows 10, CIFS: Authentication for user [user] has FAILED

Upgraded to OS5 today: 5.04.114. Now I cannot access the device from my Windows 10 machine. Right before the upgrade, I could access the device through the file explorer.

I have a second WDMYCLOUD that I am still able to access from my Windows 10 machine.

I tried all the things on the internet but I continue to get SAMBA, CIFS: Authentication for user [user] has FAILED.
On Windows, it will attempt to open the directory but will ask for a password for the user. If I put in a fake user name it will fail and not ask for a password (because they don’t exist). So, I assume that when I put a username that the SAMBA recognizes, it then asks for the password but then the password fails. If there is some sort of secret password other than the one I use to log into the dashboard, I don’t know it.

Below is a list of different things I have tried. I would try one thing at a time, then revert it back after it failed.

Things I tried on the PR2100:
I have tried changing the password.
I have tried changing the SMB3 to all the other combinations.
I created a new, second user and password and attempted to use this new user.
I have created test folders and test users and test passwords and test groups with users added.
I have double triple checked that the folders are set to ‘Public’ and I have access for the user.
I turned ‘Public’ off and on.
I clicked probably every box under “Windows Services.”
I did a ‘System Only’ restore.
I have SSH’d into the PR2100 to make sure SAMBA is running. Ran ‘testparm,’ it printed all the public drives and such. Says a bunch of stuff I don’t really understand, attached below.
Rebooted a ton.

Things attempted in Windows 10:
I have checked and rechecked my credentials and login info.
Attempted to login using the Local Account “admin” username and password (about 100 times).
I have gone into the adapter settings and messed with the NetBIOS settings.
I have added regedit keys.
I have disabled the firewall.
I tried following many online tutorials on how to configure a network drive.

Seeing as though I cannot go back to OS3, this is a big, big issue and I really need to find a solution. Feeling a bit duped into upgrading! This breaks my ability to add large files to the server. This is a big problem.

HELP!

Edit: plex still works. I can access the device from the web and my phone app.

Update: I was able to access the device in Windows 10 File Explorer on my Laptop. Still don’t know what is causing the failure on the Desktop machine. Looking through the laptops settings to see if I can find the difference causing the issue.

Solution: Found the issue. For some reason I needed to change a register Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\LmCompatibilityLevel to 4

testparm -s dump:

root@MyCloudPR2100 ~ # testparm -s
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Registered MSG_REQ_POOL_USAGE
Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[Photos]"
Processing section "[Public]"
Processing section "[SmartWare]"
Processing section "[TimeMachineBackup]"
Processing section "[entware]"
Processing section "[DVR]"
Processing section "[Temp]"
Processing section "[Volume2]"
Loaded services file OK.
WARNING: socket options = IPTOS_LOWDELAY TCP_NODELAY SO_RCVBUF=4096000 SO_SNDBUF=4096000
This warning is printed because you set one of the
following options: SO_SNDBUF, SO_RCVBUF, SO_SNDLOWAT,
SO_RCVLOWAT
Modern server operating systems are tuned for
high network performance in the majority of situations;
when you set 'socket options' you are overriding those
settings.
Linux in particular has an auto-tuning mechanism for
buffer sizes (SO_SNDBUF, SO_RCVBUF) that will be
disabled if you specify a socket buffer size. This can
potentially cripple your TCP/IP stack.

Getting the 'socket options' correct can make a big
difference to your performance, but getting them wrong
can degrade it by just as much. As with any other low
level setting, if you must make changes to it, make
 small changes and test the effect before making any
large changes.

Server role: ROLE_STANDALONE

# Global parameters
[global]
        disable spoolss = Yes
        dns proxy = No
        ldap ssl = no
        load printers = No
        local master = No
        map to guest = Bad User
        max log size = 10
        max xmit = 131072
        min receivefile size = 16384
        os level = 0
        passdb backend = smbpasswd
        preferred master = No
        printcap name = /dev/null
        security = USER
        server min protocol = SMB3_00
        server string = MyCloudPR2100
        socket options = IPTOS_LOWDELAY TCP_NODELAY SO_RCVBUF=4096000 SO_SNDBUF=4096000
        unix charset = UTF8
        unix extensions = No
        winbind offline logon = Yes
        fruit:veto_appledouble = no
        fruit:nfs_aces = no
        fruit:copyfile = yes
        idmap config * : backend = tdb
        aio read size = 0
        aio write size = 0
        allocation roundup size = 0
        create mask = 0777
        csc policy = disable
        delete veto files = Yes
        directory mask = 0777
        force create mode = 0777
        force directory mode = 0777
        strict allocate = Yes
        use sendfile = Yes
        veto files = /:2eDS_Store/.bin/Network Trash Folder/.systemfile/lost+fou                                     nd/Nas_Prog/mirrored/uploaded/.wdmc/.AppleDouble/
        wide links = Yes


[Photos]
        guest ok = Yes
        map archive = No
        path = /mnt/HD/HD_a2/Photos
        read only = No
        vfs objects = catia fruit streams_xattr


[Public]
        guest ok = Yes
        map archive = No
        path = /mnt/HD/HD_a2/Public
        read only = No
        vfs objects = catia fruit streams_xattr


[SmartWare]
        guest ok = Yes
        map archive = No
        path = /mnt/HD/HD_a2/SmartWare
        read only = No
        vfs objects = catia fruit streams_xattr


[TimeMachineBackup]
        guest ok = Yes
        map archive = No
        path = /mnt/HD/HD_a2/TimeMachineBackup
        read only = No
        vfs objects = catia fruit streams_xattr


[entware]
        guest ok = Yes
        map archive = No
        path = /mnt/HD/HD_a2/entware
        read only = No
        vfs objects = catia fruit streams_xattr


[DVR]
        guest ok = Yes
        map archive = No
        path = /mnt/HD/HD_b2/DVR
        read only = No
        vfs objects = catia fruit streams_xattr


[Temp]
        guest ok = Yes
        map archive = No
        path = /mnt/HD/HD_b2/Temp
        read only = No
        vfs objects = catia fruit streams_xattr


[Volume2]
        guest ok = Yes
        map archive = No
        path = /mnt/HD/HD_b2/Volume2
        read only = No
        vfs objects = catia fruit streams_xattr
3 Likes

You saved my life [blackbox098]
I had the same problem after MyCloudEX2Ultra upgrade to OS5.
3 of my 4 windows computers could access my MyCloudEX2Ultra files but 4th computer with Windows 7 could not.
I had to change and test many things with no luck.
In my case solution was this registry key change AND setting SMB Protocol to SMB1, SMB2, SMB3

Thank you in advance [blackbox098]

Thank you for the solution it worked for me with OS5.

Hi,
I think i am in a desesperated situation than you, where in my main PC, i can’t access or map unit from my Windows explorer with always incorrect credentials. In other W7 i can access or in other second W10 also i can.
How did you reach that solution? Do you have information about that?
W10 OK -> LmCompatibilityLevel =5
W7 OK -> LmCompatibilityLevel =3
W10 NOK -> LmCompatibilityLevel =1

Can i have your same problem?

Thanks a lot for your support.

Yes, it was the same problem. That key on regedit corresponds with Network security: LAN Manager authentication level. As in the other W10 that was working i have selected “Send NTLMv2 response only. Refuse LM & NTLM”. Thanks, i saw the light with your post.

1 Like

I had a similar issue with OS5 Uprgade and after searching a lot did the following to get it working

  1. Open your WD NAS Webinterface
  2. Go to Settings
  3. Go to Network
  4. Go to Windows Services
  5. The Allowed SMB protocol will be SMB 3 and you change it to SMB 2 and SMB 3

your windows 7 device would be able to access the shares again.

Do let me know if it works for you.

Thanks
Dilip
ChipinCorp

Unable to access any mount without making it public. tried changing SMB protocols, reinstall in my laptop, etc and still seeing the same exception. Any help from WD support please.

2021 Feb 27 13:03:01 SAMBA CIFS: Authentication for user [user_name] has FAILED.

FYI… i am using My Cloud EX2 Ultra…

The following KBA will help.

My Cloud OS 5: Change Windows Samba (SMB) Protocol Version

Answer ID 29958

I will like to put down here my findings about this issue. I recently upgraded my WD (used as Backup unit) and I encounter an issue with my backups not working. After following the indications here by changing the registry key of LSA to 4. Although, it worked at the beginning, this registry value keep reverting to 2 after a while. Digging on what it was proposed I found out this is related to the authentication value used in the network. So the real solution was to change the settings on the WD unit itself, in my case it was a PR4100, setting the protocol to NTLMv1 & NTLMv2.

Hope this help some else out there!

1 Like

Thank you, thank you!! After trying everything else, this registry edit solved all my problems. Next time I won’t be too quick to upgrade and change user passwords all at the same time, until I have verified original access is still there. Thanks WD for making this so difficult.

I would buy you a beer or coffee if I could.

Cheers,

Nigel

I have been looking for a way to solve this. My laptop with Win10 home edition did not have this problem and the key: LmCompatibilityLevel does not exist in this version of Windows. The problem was on the Windows 10 Pro, v 21H1, OS build 19043.1415. Is this intentional by Microsoft or a misconfiguration? BTW, how did you come up with this? BRILLIANT!!! Fixed my issue.