Help "Windows cannot access \\mycloud-######"

i have a mixed wi-fi/ethernet network.
Ethernet: (to router) 2 Win10 PC’s & 1 My Cloud Home NAS device
Wi-Fi: 3 iPads, Roomba, Brother MFC printer
the message “Windows cannot access \mycloud-05d1xf” appears on only ONE of my 2 win10 pc’s
i dont want to do a reset on my device since it works fine on one computer
i have restarted my pc several times & updated the WD Discovery app


Be sure the second computer has SMB 1.0 selected.

Enable File Sharing Support on My Cloud, Home & Passport in Windows (


Get My Cloud to show in Windows 10 File Explorer Network - My Cloud OS 3 Personal & Network Attached Storage / My Cloud - WD Community

Here is the message - as you can see, "mycloud-05d1xf” shows up in the network, but PC cannot access it:

i ran network diagnostics, but no problems detected.

Command Prompt: The network name cannot be found.
Turn on the SMB 1.0 support feature from Control Panel: already turned on
Turn on network discovery and file and printer sharing options: already done

followed all steps on this video: (Cannot See Other Computers on Local Network Fix - YouTube)

The syntax to map to drive Y for example:
net use Y: \\MYCLOUD-05D1XF\Public

to see the mapped drives:
net use

to see directory
dir Y:

if it still failed, go to device manager and delete the network adapter and reinstall the driver. Be sure you have a driver available if it is an unusual adapter.

Open a support case with WD will probably result in more detailed explanations. WD support does not use this forum for individual support, usually just generalized answers.

Thanks, I have it like that, this stop working afte the last SW update from WD, I can not even ask support, the site seems down.

1 Like

“net use Y:\MYCLOUD-05D1XF\Public” is what i used initially.
i have since reset (soft reset) my cloud home NAS & retried net use Y:\MYCLOUD-05D1XF\Public & still get the same answer: The network name cannot be found.
i’ll try opening a support case @WD site.

You need to turn LAN access on.
You most certainly have been updated to 8.12…
It’s a NEW feature.

how do i turn on Lan access?
v. 8.12… of what software


I would like to “turn LAN access on.” But I really have no idea how to do this.

“You most certainly have been updated to 8.12…” v 8.12… of what exactly?


Paul Sauvé

Of firmware.
See: My Cloud
And: How to Enable Local Network Access to Data on My Cloud Home and ibi Using the Dashboard

logged on to
web app version of My Cloud Home: 8.12.0-178

select menu ―> pausau’s My Cloud Home ―> MANAGE DEVICE ―> CONTINUE ―> click Sign in ―> set Local network access to On (Enable network access to access devices on the same network.)

still cannot access from my Windows 10 pc

Trying my luck there.

What about this?

unfortunately, this is NOT the message i’m getting.

  • i did switch to local user & all the services in the list are running.
  • i rebooted my PC & my modem (which ‘sees’ the MYCLOUD NAS) connection
  • UPnP enabled on my router

PLEASE NOTE - this problem started when WD Discovery was updated on the computer that no longer connects to MyCloud Home…

I resolved the problem by reinstalling Windows on my PC!!!