Where can I find the FTP URL link on a 2TB WDMyCloud?

Hi guys,

I’m a happy owner of 2 x 2TB WDMyCloud drives for over three years now and they are both working fine (more or less - one has a red LED on all the time but still works fine)…

I’m trying to save some video footage from an IP camera directly via FTP into a share on MyCloud but I can’t seem to find anywhere the link of the FTP to properly set the IP camera.

Can anyone help please with some examples of links and how to identify my link to my share?

Yes, I have enabled the FTP feature in Network Services and on the user share but where can I find this URL link text please? Thanks guys.

Would attach some screen shots but haven’t figured out yet how to do that on this forum…still working on it…

Here is what my IP Cam needs: a path which I can’t figure out…

Is your MyCloud configured with DHCP, or is it statically assigned?

I prefer static addresses for appliances like these, but your mileage may vary.

If you use a static IP, this is easy. It is:

ftp://[ip address of mycloud]/[share name]

EG, mine is statically configured at 192.168.0.129, so the FTP address would be

 ftp://192.168.0.129/Public

Thanks for your input Wiered_w

Mine if fixed IP too and have tried the link using my IP and my share, saved it and the test failed:

I’ll try different ports maybe that’s the issue…

Port should be 21. That is normal for FTP transactions.

the “Path” part is where you are going to be storing the camera feeds. It is a path relative to the root of the FTP server.

MyCloud’s FTP implementation shows FTP accessible shares as if they were folders under the root, so if you have a share you have created for camera feeds, let’s call it “Camera_Feeds”, you would give it a path like this

 /Camera_Feeds
1 Like

Thanks mate. Have made some progress: the path is not working now…I’ll try your example…

Test the path by using another FTP client, like FileZilla (https://filezilla-project.org/). That will at least confirm if FTP is working properly on the My Cloud and if the Share can be reached.

Thanks Bennor,

Not an expert so I’m unable to test your link as I think I need some credentials?

Have tried different shares on the same WD My Cloud, the path seems to be the issue here:
2018-03-29 (6)2018-03-29 (5)

The camera tab says under path that the path starts with ./

Here is the view of a refressed camera:

So weird! I’ve tested and the FTP is working in CMD but how do I find the correct path???

Huh? The link I provided goes to FileZilla website where one can download the free FileZilla FTP program to their computer. The point is to use an alternate program to test for FTP access including the ability to write files to the My Cloud using FTP.

Works fine:
Connecting to 192.168.1.8:21…
Status: Connection established, waiting for welcome message…
Status: Initializing TLS…
Status: Verifying certificate…
Status: TLS connection established.
Status: Logged in
Status: Retrieving directory listing…
Status: Directory listing of “/” successful
Status: Retrieving directory listing of “/IP_Cam”…
Status: Directory listing of “/IP_Cam” successful

So the WD My Cloud is accepting files via FTP but I’m unable to establish the correct path in my IP Cam

Try entering just the share name for the path. Don’t include the ftp & IP prefix. You have already told it that it is using FTP, and given it the IP address and port. You don’t need to provide those values in the Path. The Path is just the folder location on the FTP server you have identified.

i.e. do as Wierd_w suggested…

Bingo!

Many thanks to all of you guys! It’s finally working:

You’re amazing all of you guys! Happy Easter!

Hi.
Can you explain how you got it?
I have the same problem as you and I cannot connect my camera via FTP to M Cloud.
thanks