Whenever shall we see improved firmware?


the latest mine is showing me is 1.02.25 back in Jan which version are you using on Feb 25th? 

EX4Shot wrote:

Keep in mind and Ill share what others have reminded me.  This is not a true WD tech forum.  its a user community in which WD monitors.  But does not truely interact as you would expect a tech forum to do.  We are all just trying to help each other here.


On a side note, WD techs will tell you alot, and some blatently incorrect such as I have discussed and proven here.  I hope you have a support ticket number where they promised you “anything”.  There is a “WD Support Portal” that you can look at your email to see if they created a ticket there.  If you just phoned in, I am not sure if they creat tickets.  (But when I look at my account, I am missing a lot of calls I have made to WD.  


My advice would be to:


  1. Open an offical support ticket in the WD Support Portal


  1. Call and open an official support ticket for your issues.  


Thats the only way it will truely be in thier system.


Regarding questions about update. The latest firmware was on the box when I bought it late 2013. It has not been updated since, and remains as 1.02.25.

This needs updating to reach a level that allows proper usage of the EX4 and that matches other makers NAS offerings.

With the current device and firmware WD will never have a true cloud device with the rate they fix problems. With the massive amount of issues and the staggering lack of features WD needs to get to work fast. Take a look at any of the Synology products or any other NAS device. Their user interface and capabilities for their entry level products are years ahead of what WD has for their thousand dollar EX4.  

The sad part is WD will relase a firm ware fix eventually that will fix one problem and create 4 new ones.

Automatic update to 1.02.36 and so some things have been cured. But concurrent Cloud Access and Active Directory has still not arrived. This is ridiculous.

Something strange has happened. I was out, watching Everton v Manchester United, with my football mad friends. I came home to do some work and noticed, at the foot of the Network table on my computers the icon named WDMYCLOUDEX4 which had not been there when I left home this morning.

I was able to open this icon using the administrative username and password, and my Cloud Access still works. This is true, even if the dashboard still tells me that it’s not possible to have both together!

As is the case with my Seagate NAS, a couple of the computers won’t join, but that’s typical of Windows 7, except, in general, my EX4 also can be visited over the Windows Server 2008 R2 Active Directory network that I run. Wonderful!

I do hope somebody in the WD crew can explain this, because . . . . . .

The new firmware that was just released solved several problems for me including the high CPU usage.  We still need new firmware to resolve other issues but so far the new release works better than the previous version.

My latest situation can be seen in ‘Absurd connection issues’ under my user name.