WD4 Firmware update 210302

Hi,

after installing firmware update 210302 WD4 is freezing and is not accessabel anymore. after unplugging the power and restarting the system it works for about 15 minutes (in this time the system is heavily working) ,then the freeze will come up again. What can I do?

Cheers

Chris

Hello,

We have passed this along to support.

My EX4 auto updated itself and now I can no longer get it to mount as a network drive on my MacBook Pro.  It worked fine up until the update.  ALL of my media files about 5TB worth are sitting on this and now I can’t get anything.  Not happy at all.

1 Like

I too am having this problem since the update.

I’ve been locked out from my drives today now too since the firmware update.

27" 2013 iMac

OSX 10.11 (El Capitan)

I can log into the web admin just fine. View and access files from there, but now there is no way to connect to the drives in the system browers. Tells me unable to connect. Same IP addresses. The drive is recognized and shows up fine everywhere else. Even the My Cloud EX4 software sees the drive but is unable to access to make the file browser connection.

I really need to access these files. 

It now is showing me this (attached image) Screen Shot 2015-09-23 at 6.05.01 PM.png

Ok, I was able to fix my connection issues by enabling these two settings which were off (either always or now due to the firmware update). AFP Service and WebDAV Service.

Firmware 2.10.302 was installed on my EX4 last night at 3am, which broke my MythTV backend.

For some reason (I’m assuming because of this firmware), the 2 public shares from the NAS were no longer group writable by my Linux box anymore (Ubuntu).   The shares were still readable by group, and read/writable by user only.  Fix was to add file_mode=0666,dir_mode=0777 to the fstab entries.

Full working fstab entries look like this (I use JBOD)

//192.168.1.4/bay2 /mnt/nas/bay2 cifs username=public,password=,iocharset=utf8,uid=1000,gid=124,file_mode=0666,dir_mode=0777 0 0

I’ve turned off the auto-application of firmware updates.  Looking forward to the release notes being made available, when WD think that’s worth doing.  grrrrr

I am having similar problems… 

The NAS does NOT show up in FILE EXPLORER/NETWORK on multiple machines (win7pro, several win10 home, and 2 linux mint).  It ALWAYS did without fail before the latest update.

But, the mapped network drive on the win7 machine still works.  Also, I just found that if I type in \Mycloudex4 (my box’s name) it will work and I can see the contents of the NAS.

Wassup wit dat?

WOW. This unit has been nothing but problems since I bought it almost 2 years ago. The freezes, crashes, lock ups are INSANE.

I am a IT professional with over 20 years in the biz and seeing a NAS do this, is just unheard of.

Now of course it was just working near correct the last few months and what do you do?

Update the firmware and I am RIGHT BACK where I was.

Slow gui pages.

CRAWLING in Mac trying to access it.

Unreal.

I will NEVER buy another WD storage device.

EVER.

1 Like

Well, I’m an IT professional with 25 years of experience, and its working fine for me.

That said, I would have like to have had the realease notes published on this forum.

Finally able to turn off public access.  Nice.  

With USB Backups, the rsync timeout has now doubled to 60 seconds which will help complex backups, and WD have added another process (up to 3), but I would like to have that set as a configuration parameter. I believe that rsync will still fail when the EX4 is loaded.  I’ll do some testing and report back.

And i like the new “Apple”-like flat-white look.  It is cleaner.

1 Like

EX4 was like 1st Gen iPhone but once you get a DL4100 <-- you’ll load it up to the max and host a pool party with Plex streaming in every room. OH!! and get the memory upgrade. BTW: my EX4 is strickly used for video archive and backups occur to another DL4100 (designated backup server).  Another DL2100 serves as the wife’s photo storage device.

This update has made my unit USELESS!  I now have 16TB of uselessness…

The admin web interface is so glacial, I can’t make any changes.

It won’t mount what used to be mounted before.

It’s thrashing the **bleep** out of the disks…why, I have no idea, and with an unusable web interface, can’t tell.

Really, you guys forced an update without have done any testing? Making everyone’s devices unusable seemed like a good idea?  Really?

Can we back out to an a software version that actually works?

1 Like

Hello, welcome to the community.

We have passed this along to support.

This thing is a dog; I’m not sure what software could ever salvage this anchor.  I"m so frustrated w/ the total unresponsiveness of this unit; I will NEVER recommend this product.  

Just my 2 cents: The update worked for me without a flaw. Everything works normal and I have no issues. 

No problems here either.

Or, at least, no new problems.

Hi,

below the changelog of new release:

Firmware Version 02.10.302 (9/10/2015)

Improved security

Addressed known command injection, SSH default password and CSRF security vulnerabilities

Applied fix for Poodle security issue

Improved Time Machine performance

Supports My Cloud OS 3 operating software

Supports WD Sync™ which syncs data across multiple PCs, notebooks and Mac
computers

Supports MyCloud.com web access portal and Learning Center (replacement for
WD2go.com)

Supports My Cloud mobile app with sharing and Automatic Camera Roll Backup

Supports NAT-PMP that allows automatic port forward connection on Apple routers

Supports Software Developer Kit (SDK) enabling enhanced app integration

Minor bug fixes

________________________________________________________________

To everybody have some heavy issues with V2 I suggest to rollback (manually) to older FW version.

Regards

Paulus wrote:

Hi,

 

below the changelog of new release:

 

Firmware Version 02.10.302 (9/10/2015)

Supports My Cloud mobile app with sharing and Automatic Camera Roll Backup

**** Are you able to tell me HOW the Automatic Camera Roll Backup works now?  I have had a look at the app and cannot find anything anywhere that allows me to configure it to automatically backup my camera roll, only to manually select photos. ****

 

thanks,

There appears to be an issue with the new firmware when it comes to external USB drives.  This has long been a frustration with the EX4, but it now appears to have got worse.

Despite turning off Media Scanning for the attached USB drivet, and ensuring that Twonky is not going to scan the drive, when a USB drive is attached the EX4 then fires up Twonky which then spends the next few hours scanning the device.  The result is that there is no spare CPU on the device, the disks get thrashed, and it is unresponsive to the GUI and the command line isn’t much better.

It should be pretty clear: If I have not selected the unit for media scanning, then don’t scan the bl@@dy thing!!!

Could someone get the WD Devs to work through the (very simple) UseCase of using the USB Drive for a Backup?

  • no scanning (why would you)?

  • rsync timeout that make sense (5 mins?)

  • ability to format and re-format USB drives

Surely that’s not hard?