What's my normal (non-root) user's SSH password

enabled ssh access  on my MBL I can log in with root fine but I want to be about to rsync/scp my files into the MBL with my user ‘kevin’ as owner of the file. 

I though it might be my WD2go password but it’s not. 

I checked /etc/passwd ‘kevin’ does exist but I can’t recall ever entering any other password 

I could use ‘passwd’ to reset my ssh/linux password BUT afriad I might screw something up. 

Please advise!

It’s more complicated than that.

Each user would need a home directory (presumably) defined.

You’d need to modify the ssh_config file to allow other users.

You’d possibly need to worry about “trustee” configuration of other users’ files.


Not simple, but not too complicated as well. Be careful. Something wrong and you might get locked out.

If I remember all my steps, this is what I did. Make sure you save backups copies for the files before you edit them.

  • Enable ssh:

  • Create shares, users, set passwords and permissions via dashboard

  • Allow Users to SSH:

edit file /etc/ssh/sshd_config
Change “AllowUsers” line by adding user names such as:
AllowUsers root user1 user2

  • Optional: Set users home dir: edit file /etc/passwd
    The following will set home dir to “Public”
    Change from “/shares:/bin/sh” to “/shares/Public:/bin/sh”

  • Restart ssh deamon or reboot:
    /etc/init.d/ssh restart

Test ssh for your users within the home network. If all works, then proceed to:

  • Set your router to forward port TCP 22
  • Set DDNS on your router