How to change root password on MBL for SSH

I periodically enable SSH on my MyBook Live and then disable it after I have finished using it.  I have never changed the default password for root via the SSH UI window.  I am almost certain that when I first enabled SSH on the MBL - it also gave me the option to change the password for root - however - now when I go into the SSH UI window - I only have the option of enabling or disabling SSH - it shows me the password but does not allow me to change it.

Do I need to change the root password after logging in to the MBL via SSH and use the “passwd” command to change the root password - and if I do that - will the MBL system processes have an issue because I have changed root’s password - and will it continue to show me the modified password in the SSH UI window?

I want to change the root password because I am thinking that I need to keep SSH enabled in case the MBL becomes bricked.


Good idea to keep SSH enabled.

SSH to MBL; cmd fo change password:  passwd root

Will be prompted for new password & confirmation.

To “restore” password to default, just press the “reset” button for 5-6 secs.

1 Like

Thanks,  I finally got around to trying this.  It worked as stated.  I did this on my spare MBL just in case something went wrong.

I noticed that even after you change the password - the MBL UI still shows the original password.  Out of curiosity - I did a quick factory restore and tried setting up SSH to see if it would allow me to specify a new password for root - and it does not.  I am now wondering if I am confusing the MBL with something else where I changed the root password - possibly confusing the MBL with maybe enabling the root login on a Mac (which is not a good practice).

Anyway - if anybody remembers the MBL UI allowing them to specify a new root user password - please let me know.


The MBL UI password is the OWNER’s password, totally separate from the root password of the OS which is done as a telnet session. Unless you have created a “root” in the add user utility? Read that the reset does reset the OS root password BUT then also read that it resets the MBL owner password in the manual. No idea which is correct. The new sign-in for the forum **bleep** big time! light blue on a blue background to get a new crypto or help??

Thanks - I am aware that the root user is at the linux level and the owner (admin) user is at the MBL level - and that both are reset to their respective values after a factory restore.  I was really questioning whether anyone had ever noticed in the ssh enablement UI - whether it ever allowed a new password to be specified for root from that screen.  So far it appears that the ssh enablement screen in the UI will always show the default root password - even if you log in to the MBL as root via SSH and change the root password in Linux via the passwd command.  I was also curious to know whether anyone has had SSH enabled (with a changed root password) for a long enough period to determine whether the MBL’s background processes are impacted in anyway by having changed the root password at the linux level?


The background processes are not affected by changing the root password.

Thanks Myron - I will trust you on that.


I’m a newbie here.  Does anyone know how to change the SSH password using WinSCP?  I search for the answer here and on google but can figure it out.  Thanks in advance.

Downloand PuTTY - it’s a free ssh client.  Just google google “putty for windows” and find a download for your specific windows platform.

After you have PuTTY installed - configure a session to connect to your MBL - login as root - and use the passwd command to change the root password.

Here is a link to a quick-start guide on using PuTTY - and also contains a link to the download site.

Putty Tutorial and Download