What username/pw format to use when mapping drive?

I have created a share on my EX4 that is NOT public.  I have assigned a user to this share. I can see the share when browsing on my network to the device, but when I try to connect I get the username/pw dialog.  I can not figure out what format to use for entering the user/pw.  Please help.



What do you mean by format? You use the user ID of the user you assigned rights to, and the password for that user.

On a windows computer it thinks I am doing this as part of a domain on my local computer.  

Assume user name :   stacey

i have tried entering    user: stacey

                                        pw:   mypassword

i have tried   user:  \stacey

i have tried full email

 i have tried mycloudname\stacey


What are you seeing that makes you think domains are involved?


Yeah, I think that doesn’t mean anything… That’s just your PC name, right?

Yes. that is my computer name. But nothing i have tried allows me to connect to map the drive

Open up a CMD window and enter the command

net use

Let me know the contents of what you get back.

It works correctly for private shares for me when doing the same thing.

On that username/password screen, I can enter the username and password of the user that I created within the dashboard of the EX4 and it connects (ignore the name shown in the domain box of the prompt).

It works correctly for me provided I have assigned the rights to the private share to this user from within the dashboard.

Can you login to your EX4 dashboard and verify if the share you created is marked private and has rights assigned to the user that you are trying to connect as from Windows?

Also try to make that share public and see if you can access it without password first and try copying some files to at least make sure everything else except the password is setup correctly.

If I mark the share as public, I can access it with no problem.

Without using the net use cmd, I can see all the shares on the device. I can access the Public share, or if I make any other share public I can access those.  It is just once I mark it as private that I can’t. I have made sure that the user that I want to use has read/write permissions to that share.


Try resetting the password of this user from within the EX4 dashboard and see if that makes a difference.

Do you have any other user created on EX4? Can you try to use that other user and see if the same problem happens for any such user?

slevine wrote:

Without using the net use cmd, I can see all the shares on the device.

Well, no doubt.   But the net use command will tell you if there’s a cached connection already.

If there is, Windows will NOT allow you to connect to a private share because it will have different credentials than what is in the cache.

ANYTHING in the cache will work to connect to Public shares, hence the question.

So… the final oddity. If I use the net use command I can successfully map a drive. I am still unable to map a drive through windows though. Any thoughts?


That means you are able to access the folder now with a mapped drive using the net command?

If you try to map a drive using the Windows explorer, it still does NOT work?

Can you try again to map a drive using explorer and entering the username (when prompted) as “\username” and the password to see if that works?

So if your username was stacey and your EX4 was WDMyCloudEx4, try using


as the username when prompted and see if that helps.