What does the Port Forwarding option do on MyCloud (gen 2)?

I understand port forwarding in general … as setup on a router. But what does the port forwarding setting do on MC? The option is available for HTTP, HTTPS, and the 2 FTP ports. A scan is involved by default, but there is also a manual definition where the internal and external ports are specified.

The reason I ask: I am trying to enable the FTP server on my MC device - accessed only from devices on my LAN. (I do not want any access from the internet.) I can get at the FTP server from multiple FTP clients on my PCs, but not from the Acronis True Image built-in FTP client. A WD technician said I need to enable port forwarding on my router and on MC. I’m pretty sure I do not, but I thought I should find out what the port forwarding setting on MC actually does.

What port are you attempting to connect to? Port 21 or some other port? What specific error is Acronis generating when it cannto connect to the My Cloud FTP server? Are you using the correct My Cloud IP address?

See this Acronis Support document for more information on various FTP issues with their software:

Generally you only need to specify different ports when the default configuration ports for the My Cloud do not work. Either due to other internal local network port settings or because one’s broadband provider blocks the ports for inbound or outbound traffic.

If you haven’t done so already you should read the My Cloud User Manual which generally explains the various features/settings of the My Cloud, and or read the My Cloud Dashboard Help.

Yes, I am connecting to port 21. Acronis TI says “Connection failed”, but it actually does connect. A packet trace shows a reasonable exchange going on - Acronis issuing the FEAT command, the server prompting for id and password (and Acronis providing them), Acronis issuing SYST, PWD, OPTS MLST (with the server responding to each). Then Acronis issues “MLST /”, the server says “550 Can’t check for file existence” and Acronis stops talking. I assume that’s when it issues the “Connection failed” message. It doesn’t even terminate the connection it claims failed.

This is clearly an Acronis bug, and I’ve reported it to Acronis. (If nothing else, it’s an error not to terminate the connection.) But the WD technician actually got it to work for 2 transfers so I know there is some set of conditions that can circumvent the problem.

Edit just realized Pokeefe started the other two threads I linked to and were still having the same problem with Acronis.



Yes, I started those threads. Each is from a different perspective as I’ve tried to deal with problem. My latest take is: regardless of possible bugs on either or both sides, the WD technician got the transfer to (briefly) work. Therefore, there is a way.

I’ve tried going over various things the technician did. My latest is trying to see if the port forwarding stuff could possibly have an effect.