Can't access MyCloud drive via FTP

I’m trying to access my device via FTP but I see no way of doing it. All the instructions say to do is to enable FTP and create another user – nothing else. I see no way to enable your FTP client to access the drive.

Also - on my router I have another drive hooked to its USB port. It defaults to port 21. Does this mean I have to port forward the MyCloud device to port 22?


@humb_gar What device do you own? Is it a 1st generation My Cloud? See image below for using FTP. Click on, tap, or activate image to enlarge it.

Look at all Help information provided. image

You have to enable FTP service in the My Cloud Dashboard.

How To Configure FTP Server Access on a My Cloud

Or click on Support top right and select your My Cloud model then review the My Cloud User Manual which typically had information on enabling FTP on the My Cloud.

Thanks for your replies. I managed to log in via FTP but only locally (i.e., when on the same network) but not remotely, assuming that’s even possible.

The device is a model WDBCTL0300HWT-00 which I bought probably 3 years ago. Don’t know what generation it is, although it says MyCloud 3. I’m not seeing any way to configure port forwarding as shown in the link you pointed out. The files can be accessed remotely with the browser and with the Android app, but not with FTP.

Can it be done, and if so, how?

First, a general warning. about using FTP for remote access. FTP is not a secure method to file access. Generally there is no encryption of files and one’s FTP username/password may be sent as plain text, meaning it could potentially be intercepted and used.

To enable remote FTP access to one’s My Cloud. After enabling the FTP service within the My Cloud Dashboard, one generally has to enable port forwarding within their router to forward the FTP port through the router firewall to one’s My Cloud. One would need to access their network router, navigate through the router’s administration settings, find the Port Forward section, then enable (typically) Port 21 so that port is forwarded to the My Cloud MAC/IP address. See your router’s documentation or search the internet for your router model for more information on Port Forwarding and how to do so on your specific router.

If one wants a more secure method of access they will likely have to use other methods. Such as trying to use SFTP which may involve using SSH to modify the My Cloud firmware to support such a method of access. One can search this subforum (magnifying glass icon upper right) to find past discussions on trying to use SFTP with the single bay My Cloud units. Or one can bypass using FTP and setup a VPN server on their local network. A properly configured VPN server will allow secure access to one’s local network. One can search the internet for various VPN server programs. Some consumer routers include a VPN server as well.


I’m aware FTP is insecure compared to SFTP. Relax, only I use it and then only briefly :grinning:

Regarding port forwarding, I’d have to configure the WD drive to port 22 because I have another drive attached to the router’s USB port which defaults to 21. The question now becomes: how do I tell my WD device to expect FTP calls on port 22? The port forwarding configuration screens shown on the link above don’t appear on my device. It’s either too old or I’m not looking in the right place.

Even if I did all this, now comes the next question: how exactly do I configure the FTP client to access the device remotely? On the link it shows 2 configurations: ftp://IP_ADDRESS/Share and ftp://MyCloudUser@IP_Address. The first works great for local FTP access. The 2nd one I don’t understand. This is remote access, 192.168.XXX won’t work. I’d guess it’s got to be something like ftp://wd2go or similar. Also, when they say “MyCloudUser”, do they mean the user name on the device or the email address to log in? Is there any way someone can give me and example of the proper FTP remote configuration using a nonexistent device or something?

For remote access, one could try leaving the My Cloud at Port 21 and within the router’s administration screen configure port forwarding to the My Cloud such that the external port is Port 22 and leave the internal port a Port 21. Such a port forwarding configuration should route broadband external Port 22 to the the internal network My Cloud’s Port 21.

For remote FTP you use your broadband router’s external IP address. If you don’t know what your external broadband IP address is, sites like should show you what your external IP address is.

Hi again.

So basically I should attempt to connect remotely by forwarding port 22 to the router while leaving the router settings alone. OK, let’s try it. I’ll let you know.

With respect to the proper configuration on the FTP client, the link you gave me as well as the ipconfig /all command spits out my IPV6 address. As you know, each device on the network has a unique IPV6 address (i.e., there is no NAT). For that reason I’m assuming you mean the router’s IPV4 address. I finally found it after doing some digging.

Let’s assume my router’s IPV4 address is The setting should be ftp://MyCloudUser@ (right?) - now comes the MyCloudUser part. There are 2: an email address and password for login, and a user I created with it’s own password. On local access I use the user I created. Should I do the same for remote?

Finally, do any of you guys know of a utility that will tell you the IPV6 address of each device on your network? I’m thinking it might be possible to bypass all this port forwarding jazz by going directly to the WD device’s IPV6 address. And, as we all know, one day in the not too distant future IPV4 will go the way of the floppy disk.

Generally one is using IPv4 not IPv6 when working with FTP and the My Cloud.

One generally has to enable port forwarding within their router to get remote FTP access to work. When port forwarding within the router one typically sets the external broadband port (example port 22 in this instance) and a local LAN port (example port 21 in this instance) and the LAN side client device the traffic should be routed to (example the My Cloud in this instance).

For FTP one uses their My Cloud User account name and Password. One does not use the username/password for FTP access.

To use IPv6 one would need to ensure the FTP server (on the My Cloud for example) supports IPv6. One would likely still have the same issue of port forwarding (port opening) through the local network router’s firewall even when using IPv6.

Thanks for your help but it didn’t work. I used user@ both with and without 22. This after configuring port forwarding to 22 external and 21 internal to the 192.168.XX address of the WD drive. All I get is “Host Not Found”. I’m now under the impression this thing doesn’t support external access via FTP. Oh well…

External broadband FTP access works just fine on my first gen v4.x single bay My Cloud. Even when using external port 22 being forwarded to the internal port 21 on the My Cloud. Works using an Android smartphone and a Windows 10 PC (FileZilla). Have port forwarding configured in my network router to pass port 22 to port 21 on the My Cloud.

Likely you have a configuration issue or perhaps your broadband provider is blocking inbound ports like FTP/SFTP ports.

Hey again,

I got the damm thing to work!! Here’s what I did:

With respect to port forwarding, your instructions were on target, i.e., port forwarding external port 22 and internal 21. The part that’s wrong (or at least did NOT work) were the instruction that say ftp://MyCloudUser@my-ip.

Accessing my other drive (the one on the USB port) remotely is done via Netgear’s ReadyCloud service which goes through It then occurred to me to use exactly the same service, only port forwarding the WD device according to your instructions. It worked!! I can access remotely now.

Thanks for your help.