Western Digital My Book Esentials has locked itself and I can't access

I have the My Book Esentialsdrive and have been using it for a couple of years, worked fine last night and this morning I suddenly can’t see it…I have found that it has auto locked itself and I never set up a password to begin with and have never updated any of the firmware…I need to access the drive or I am gonna lose thousands of dollars…please help me…

Try accessing it with a different user account like the guest account or on another computer. Other that that it will probably take professional data recovery.


1 Like

Yeah tried using different computer but still not able to see the drive. But thanks for the tip.

I contacted Western Digital and told them I never set a password that it locked itself. 

The reply I got stated that since I can’t remember my password there is nothing I can do…I should reformat the drive to resue it

As if I would ever risk using the drive again after it locks me out without a password…

It seems they refuse to acknowlege that they have a serious defect in their drive and wish to lay the blame on the customers.  Is there any hope of unlocking a drive that has locked itself, anyone please I need real solutions.

Sadly there is no password reset or work around. Removing the drive from the case and connecting as an internal won’t work either it’s hardware encrypted.